summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-06-05 14:42:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-06-05 14:42:57 +0000
commit981d0433773f67b9d233a57e6f6a8acd9e5798d3 (patch)
tree0b0107939b9ea5f786dba8529dac1f60cca77ecd /openwrt/target/linux/Makefile
parent63dab52461925d107ba9681aa0f9a5292f83e924 (diff)
downloadmtk-20170518-981d0433773f67b9d233a57e6f6a8acd9e5798d3.zip
mtk-20170518-981d0433773f67b9d233a57e6f6a8acd9e5798d3.tar.gz
mtk-20170518-981d0433773f67b9d233a57e6f6a8acd9e5798d3.tar.bz2
add rebuild target for the linux directory
SVN-Revision: 1149
Diffstat (limited to 'openwrt/target/linux/Makefile')
-rw-r--r--openwrt/target/linux/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/openwrt/target/linux/Makefile b/openwrt/target/linux/Makefile
index ced6dca..d1b4d54 100644
--- a/openwrt/target/linux/Makefile
+++ b/openwrt/target/linux/Makefile
@@ -11,6 +11,9 @@ $(1)/$(2)-prepare:
$(1)/$(2)-compile:
$(MAKE) -C $(1) BOARD="$(2)" compile
+$(1)/$(2)-rebuild:
+ $(MAKE) -C $(1) BOARD="$(2)" rebuild
+
$(1)/$(2)-install:
$(MAKE) -C $(1) BOARD="$(2)" install
@@ -18,15 +21,17 @@ ifeq ($(BR2_LINUX_$(3)),y)
clean: $(1)/$(2)-clean
prepare: $(1)/$(2)-prepare
compile: $(1)/$(2)-compile
+rebuild: $(1)/$(2)-rebuild
install: $(1)/$(2)-install
endif
-.PHONY: $(1)/$(2)-clean $(1)/$(2)-prepare $(1)/$(2)-compile $(1)/$(2)-install
+.PHONY: $(1)/$(2)-clean $(1)/$(2)-prepare $(1)/$(2)-compile $(1)/$(2)-rebuild $(1)/$(2)-install
endef
prepare:
compile:
install:
+rebuild:
clean:
rm -rf $(BUILD_DIR)/kernel