summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/ar7
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-21 18:46:19 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-21 18:46:19 +0000
commitb80218af6abdea2aa32dbe57611bd09d7413aeeb (patch)
tree2cf9f3c22d5fa63d65c8c4283ee6044b5c0835fb /openwrt/target/linux/image/ar7
parentc534539555312db0e3aecae7df90b08819c518d9 (diff)
downloadmtk-20170518-b80218af6abdea2aa32dbe57611bd09d7413aeeb.zip
mtk-20170518-b80218af6abdea2aa32dbe57611bd09d7413aeeb.tar.gz
mtk-20170518-b80218af6abdea2aa32dbe57611bd09d7413aeeb.tar.bz2
remove trx stuff from ar7 images and flash map
SVN-Revision: 1524
Diffstat (limited to 'openwrt/target/linux/image/ar7')
-rw-r--r--openwrt/target/linux/image/ar7/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/openwrt/target/linux/image/ar7/Makefile b/openwrt/target/linux/image/ar7/Makefile
index c3ffb25..3cde04b 100644
--- a/openwrt/target/linux/image/ar7/Makefile
+++ b/openwrt/target/linux/image/ar7/Makefile
@@ -41,19 +41,17 @@ $(BIN_DIR)/openwrt-ar7-zimage.bin: $(KDIR)/vmlinux.gz compile
-o $(KDIR)/loader
$(TARGET_CROSS)objcopy -O srec $(KDIR)/loader $(KDIR)/ram_zimage.sre
$(PKG_BUILD_DIR)/srec2bin $(KDIR)/ram_zimage.sre $@
- dd if=/dev/zero bs=1024 count=1 >> $@
-ALIGN:=1024
ifeq ($(FS),jffs2-8MB)
-ALIGN:=131072
+ALIGN:=bs=131072 conv=sync
endif
ifeq ($(FS),jffs2-4MB)
-ALIGN:=65536
+ALIGN:=bs=65536 conv=sync
endif
$(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin:
- dd if=$(BIN_DIR)/openwrt-ar7-zimage.bin bs=$(ALIGN) conv=sync | head -c -1024 > $@
- $(STAGING_DIR)/bin/trx -a 1024 $(BUILD_DIR)/linux-$(KERNEL)-ar7/root.$(FS) >> $@
+ dd if=$(BIN_DIR)/openwrt-ar7-zimage.bin $(ALIGN) > $@
+ cat $(BUILD_DIR)/linux-$(KERNEL)-ar7/root.$(FS) >> $@
define pattern_template
$(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS)-$(1).bin: $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin