summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/ar7
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-09 21:49:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-09 21:49:48 +0000
commit303a8fa64eb0e2788cd1fceb7ec3733d0a3ea6ec (patch)
treed388660ed328b0bf5fe0027960385cc911a449ba /openwrt/target/linux/image/ar7
parent4f5eb26f28ee90d64ee646b84435d593acce8bf6 (diff)
downloadmtk-20170518-303a8fa64eb0e2788cd1fceb7ec3733d0a3ea6ec.zip
mtk-20170518-303a8fa64eb0e2788cd1fceb7ec3733d0a3ea6ec.tar.gz
mtk-20170518-303a8fa64eb0e2788cd1fceb7ec3733d0a3ea6ec.tar.bz2
ar7: clean up system code, add code to generate firmware images
SVN-Revision: 1386
Diffstat (limited to 'openwrt/target/linux/image/ar7')
-rw-r--r--openwrt/target/linux/image/ar7/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/openwrt/target/linux/image/ar7/Makefile b/openwrt/target/linux/image/ar7/Makefile
index ee78cc9..b2683db 100644
--- a/openwrt/target/linux/image/ar7/Makefile
+++ b/openwrt/target/linux/image/ar7/Makefile
@@ -41,10 +41,28 @@ $(BIN_DIR)/openwrt-ar7-zimage.bin: $(KDIR)/vmlinux.gz compile
-o $(KDIR)/loader
$(TARGET_CROSS)objcopy -O srec $(KDIR)/loader $(KDIR)/ram_zimage.sre
$(PKG_BUILD_DIR)/srec2bin $(KDIR)/ram_zimage.sre $@
+
+$(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin:
+ dd if=$(BIN_DIR)/openwrt-ar7-zimage.bin of=$@ bs=786432 conv=sync
+ cat $(BUILD_DIR)/linux-$(KERNEL)-ar7/root.$(FS) >> $@
+
+define pattern_template
+$(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS)-$(1).bin: $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin
+ (dd if=/dev/zero bs=16 count=1; cat $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin) | \
+ $(STAGING_DIR)/bin/addpattern -p $(1) -o $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS)-$(1).bin
+install: $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS)-$(1).bin
+endef
+
+$(eval $(call pattern_template,WA22))
+$(eval $(call pattern_template,WAG2))
+$(eval $(call pattern_template,WA21))
+
clean:
rm -rf $(PKG_BUILD_DIR)
+ rm -f $(BIN_DIR)/openwrt-ar7*
+
prepare: $(PKG_BUILD_DIR) $(PKG_BUILD_DIR)/zimage.script $(PKG_BUILD_DIR)/ld.script
compile: prepare $(PKG_BUILD_DIR)/loader.o $(PKG_BUILD_DIR)/srec2bin
-install: $(BIN_DIR)/openwrt-ar7-zimage.bin
+install: $(BIN_DIR)/openwrt-ar7-zimage.bin $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin