summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/au1000/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-04-11 12:39:33 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-04-11 12:39:33 +0000
commite8e55bc436d1d0e7a5210806fe3ea4b6c890cb19 (patch)
treee56a09fc54c5adc0467c8f8ccc10ab235ca04edb /openwrt/target/linux/image/au1000/Makefile
parentbefba55ee33caa7bd6c451b169804ad4e080ca6e (diff)
downloadmtk-20170518-e8e55bc436d1d0e7a5210806fe3ea4b6c890cb19.zip
mtk-20170518-e8e55bc436d1d0e7a5210806fe3ea4b6c890cb19.tar.gz
mtk-20170518-e8e55bc436d1d0e7a5210806fe3ea4b6c890cb19.tar.bz2
Add an MTX-1 specific patch to avoid functions redefinition at compile-time. Build a full target
SVN-Revision: 3616
Diffstat (limited to 'openwrt/target/linux/image/au1000/Makefile')
-rw-r--r--openwrt/target/linux/image/au1000/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/au1000/Makefile b/openwrt/target/linux/image/au1000/Makefile
new file mode 100644
index 0000000..04a89f9
--- /dev/null
+++ b/openwrt/target/linux/image/au1000/Makefile
@@ -0,0 +1,36 @@
+include $(TOPDIR)/rules.mk
+
+KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
+
+
+ifeq ($(FS),jffs2-8MB)
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img: $(KDIR)/root.$(FS)
+ $(CP) $^ $@
+
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
+
+endif
+
+
+ifeq ($(FS),tgz)
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz: $(KDIR)/root.tar.gz
+ $(CP) $^ $@
+
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz
+
+endif
+
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz: $(KDIR)/vmlinux
+ $(CP) $^ $@
+
+
+clean:
+prepare:
+compile:
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
+install-ib:
+ mkdir -p $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)
+ $(CP) $(KDIR)/bzImage $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)/