summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/brcm
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-21 21:07:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-21 21:07:10 +0000
commit2b279ace6acc895a0bae2d3debbd1aa964d441ae (patch)
tree4680ef6122a6da62ea510cbc35a011adc3059495 /openwrt/target/linux/image/brcm
parent194ea14a958ed805433280d84eadd3b5d07b8364 (diff)
downloadmtk-20170518-2b279ace6acc895a0bae2d3debbd1aa964d441ae.zip
mtk-20170518-2b279ace6acc895a0bae2d3debbd1aa964d441ae.tar.gz
mtk-20170518-2b279ace6acc895a0bae2d3debbd1aa964d441ae.tar.bz2
sync broadcom image build with whiterussian
SVN-Revision: 2216
Diffstat (limited to 'openwrt/target/linux/image/brcm')
-rw-r--r--openwrt/target/linux/image/brcm/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/openwrt/target/linux/image/brcm/Makefile b/openwrt/target/linux/image/brcm/Makefile
index 23072bd..73d236a 100644
--- a/openwrt/target/linux/image/brcm/Makefile
+++ b/openwrt/target/linux/image/brcm/Makefile
@@ -15,7 +15,8 @@ ifeq ($(IB),)
$(KDIR)/vmlinux.lzma: $(KDIR)/vmlinux
cat $^ | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $@ || (rm -f $@ && false)
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx: $(KDIR)/vmlinux.lzma compile
+$(KDIR)/loader.tmp.gz: compile
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx: $(KDIR)/vmlinux.lzma
endif
ifeq ($(FS),jffs2-8MB)
@@ -42,11 +43,22 @@ endif
ifeq ($(KERNEL),2.4)
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
+ifeq ($(FS),squashfs)
+$(BIN_DIR)/openwrt-wap54g-$(FSNAME).trx: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+ cp $< $@
+ echo -ne '\x01' >> $@
+
+install: $(BIN_DIR)/openwrt-wap54g-$(FSNAME).trx
+endif
+
ifneq ($(FS),jffs2-8MB)
$(BIN_DIR)/openwrt-wrt54g-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
$(STAGING_DIR)/bin/addpattern -4 -p W54G -v v4.20.6 -i $< -o $@ -g
-install: $(BIN_DIR)/openwrt-wrt54g-$(FSNAME).bin
+$(BIN_DIR)/openwrt-wrt54gs_v4-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+ $(STAGING_DIR)/bin/addpattern -4 -p W54s -v v1.05.0 -i $< -o $@ -g
+
+install: $(BIN_DIR)/openwrt-wrt54g-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54gs_v4-$(FSNAME).bin
endif
ifneq ($(FS),jffs2-4MB)