summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/squashfs.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-08-14 15:00:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-08-14 15:00:56 +0000
commit4bcd843c607e9679d73f760c6ed893822e645012 (patch)
tree6ae7a3842861995a7840e238ffcb58595335f99d /openwrt/target/linux/image/squashfs.mk
parent9791d7a2415d481dd893f00e937dc0987fa27c1c (diff)
downloadmtk-20170518-4bcd843c607e9679d73f760c6ed893822e645012.zip
mtk-20170518-4bcd843c607e9679d73f760c6ed893822e645012.tar.gz
mtk-20170518-4bcd843c607e9679d73f760c6ed893822e645012.tar.bz2
add new image builder
SVN-Revision: 1661
Diffstat (limited to 'openwrt/target/linux/image/squashfs.mk')
-rw-r--r--openwrt/target/linux/image/squashfs.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/squashfs.mk b/openwrt/target/linux/image/squashfs.mk
index 70a85b9..42ff77d 100644
--- a/openwrt/target/linux/image/squashfs.mk
+++ b/openwrt/target/linux/image/squashfs.mk
@@ -14,7 +14,13 @@ $(KDIR)/root.squashfs:
squashfs-install: $(KDIR)/root.squashfs
$(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
+
+squashfs-install-ib:
+ mkdir -p $(IB_DIR)/staging_dir_$(ARCH)/bin
+ cp $(STAGING_DIR)/bin/mksquashfs-lzma $(IB_DIR)/staging_dir_$(ARCH)/bin
prepare: squashfs-prepare
compile: squashfs-compile
install: squashfs-install
+install-ib: squashfs-install-ib
+clean: squashfs-clean