summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/squashfs.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-31 23:29:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-31 23:29:05 +0000
commit9ba9373d546ff96369d03dcf2d92486dbf7f3d26 (patch)
treecd46b0bc66c1e5df3afb9975edd6dcbd841d4be9 /openwrt/target/linux/image/squashfs.mk
parent00b53c7433a39b169c54a8da50c580d63cf798ca (diff)
downloadmtk-20170518-9ba9373d546ff96369d03dcf2d92486dbf7f3d26.zip
mtk-20170518-9ba9373d546ff96369d03dcf2d92486dbf7f3d26.tar.gz
mtk-20170518-9ba9373d546ff96369d03dcf2d92486dbf7f3d26.tar.bz2
cleanup; replace .PHONY with FORCE; disable gdb by default
SVN-Revision: 3877
Diffstat (limited to 'openwrt/target/linux/image/squashfs.mk')
-rw-r--r--openwrt/target/linux/image/squashfs.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/openwrt/target/linux/image/squashfs.mk b/openwrt/target/linux/image/squashfs.mk
index abe2156..184330c 100644
--- a/openwrt/target/linux/image/squashfs.mk
+++ b/openwrt/target/linux/image/squashfs.mk
@@ -4,13 +4,13 @@ else
endian := be
endif
-squashfs-prepare:
+squashfs-prepare: FORCE
$(MAKE) -C squashfs prepare
squashfs-compile: prepare-targets
$(MAKE) -C squashfs compile
-squashfs-clean:
+squashfs-clean: FORCE
$(MAKE) -C squashfs clean
rm -f $(KDIR)/root.squashfs
@@ -22,7 +22,7 @@ ifeq ($(IB),)
squashfs-install: compile-targets $(BOARD)-compile
endif
-squashfs-install: $(KDIR)/root.squashfs
+squashfs-install: $(KDIR)/root.squashfs FORCE
$(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
squashfs-install-ib: compile-targets