summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/squashfs.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 01:40:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 01:40:50 +0000
commitc480aa15c1cafb826d88bbce259013e7022c95ac (patch)
treef1867f82f98ef29dcb1cce4dfdf9085753934f46 /openwrt/target/linux/image/squashfs.mk
parent35d1297447cc2d8cf4c1037079beafe876094b87 (diff)
downloadmtk-20170518-c480aa15c1cafb826d88bbce259013e7022c95ac.zip
mtk-20170518-c480aa15c1cafb826d88bbce259013e7022c95ac.tar.gz
mtk-20170518-c480aa15c1cafb826d88bbce259013e7022c95ac.tar.bz2
add some more verbosity stuff
SVN-Revision: 2222
Diffstat (limited to 'openwrt/target/linux/image/squashfs.mk')
-rw-r--r--openwrt/target/linux/image/squashfs.mk18
1 files changed, 9 insertions, 9 deletions
diff --git a/openwrt/target/linux/image/squashfs.mk b/openwrt/target/linux/image/squashfs.mk
index 00411c0..30222c6 100644
--- a/openwrt/target/linux/image/squashfs.mk
+++ b/openwrt/target/linux/image/squashfs.mk
@@ -1,18 +1,18 @@
squashfs-prepare:
- $(MAKE) -C squashfs prepare
+ $(MAKE) -C squashfs prepare $(MAKE_TRACE)
-squashfs-compile:
- $(MAKE) -C squashfs compile
+squashfs-compile: prepare-targets
+ $(MAKE) -C squashfs compile $(MAKE_TRACE)
squashfs-clean:
- $(MAKE) -C squashfs clean
+ $(MAKE) -C squashfs clean $(MAKE_TRACE)
rm -f $(KDIR)/root.squashfs
$(KDIR)/root.squashfs: install-prepare
@mkdir -p $(KDIR)/root/jffs
- $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -le
+ $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -le $(MAKE_TRACE)
-squashfs-install: $(KDIR)/root.squashfs $(BOARD)-compile
+squashfs-install: install-targets $(KDIR)/root.squashfs $(BOARD)-compile
$(TRACE) target/linux/image/$(BOARD)/install
$(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
@@ -20,8 +20,8 @@ squashfs-install-ib:
mkdir -p $(IB_DIR)/staging_dir_$(ARCH)/bin
cp $(STAGING_DIR)/bin/mksquashfs-lzma $(IB_DIR)/staging_dir_$(ARCH)/bin
-prepare: squashfs-prepare
-compile: squashfs-compile
-install: squashfs-install
+prepare-targets: squashfs-prepare
+compile-targets: squashfs-compile
+install-targets: squashfs-install
install-ib: squashfs-install-ib
clean: squashfs-clean