summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/squashfs.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-11-07 17:18:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-11-07 17:18:34 +0000
commitf13242ef8f85249b5d1f5a190a3148769c91dadf (patch)
treeecbd44486b7f6b7fef004c1fdf755fcef8ec125a /openwrt/target/linux/image/squashfs.mk
parentf313afc53bb74601021014b2a1aae98b9c9331fb (diff)
downloadmtk-20170518-f13242ef8f85249b5d1f5a190a3148769c91dadf.zip
mtk-20170518-f13242ef8f85249b5d1f5a190a3148769c91dadf.tar.gz
mtk-20170518-f13242ef8f85249b5d1f5a190a3148769c91dadf.tar.bz2
fix image builder
SVN-Revision: 2376
Diffstat (limited to 'openwrt/target/linux/image/squashfs.mk')
-rw-r--r--openwrt/target/linux/image/squashfs.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/openwrt/target/linux/image/squashfs.mk b/openwrt/target/linux/image/squashfs.mk
index 30222c6..63eba44 100644
--- a/openwrt/target/linux/image/squashfs.mk
+++ b/openwrt/target/linux/image/squashfs.mk
@@ -11,12 +11,16 @@ squashfs-clean:
$(KDIR)/root.squashfs: install-prepare
@mkdir -p $(KDIR)/root/jffs
$(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -le $(MAKE_TRACE)
+
+ifeq ($(IB),)
+squashfs-install: compile-targets $(BOARD)-compile
+endif
-squashfs-install: install-targets $(KDIR)/root.squashfs $(BOARD)-compile
+squashfs-install: $(KDIR)/root.squashfs
$(TRACE) target/linux/image/$(BOARD)/install
$(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
-squashfs-install-ib:
+squashfs-install-ib: compile-targets
mkdir -p $(IB_DIR)/staging_dir_$(ARCH)/bin
cp $(STAGING_DIR)/bin/mksquashfs-lzma $(IB_DIR)/staging_dir_$(ARCH)/bin