summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/tgz.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-08-13 07:30:53 +0000
committerNicolas Thill <nico@openwrt.org>2005-08-13 07:30:53 +0000
commite29ce276cd2c6fe7c0e6df1739b930e89c13b038 (patch)
treef7344e9b785bc73588d2d16b8959a93d738880d1 /openwrt/target/linux/image/tgz.mk
parent78eee3e3d14cf24b927dd87eedc26b4c480406c0 (diff)
downloadmtk-20170518-e29ce276cd2c6fe7c0e6df1739b930e89c13b038.zip
mtk-20170518-e29ce276cd2c6fe7c0e6df1739b930e89c13b038.tar.gz
mtk-20170518-e29ce276cd2c6fe7c0e6df1739b930e89c13b038.tar.bz2
remove kernel image from rootfs archive, invoke image install like jffs2 and squashfs do
SVN-Revision: 1617
Diffstat (limited to 'openwrt/target/linux/image/tgz.mk')
-rw-r--r--openwrt/target/linux/image/tgz.mk14
1 files changed, 4 insertions, 10 deletions
diff --git a/openwrt/target/linux/image/tgz.mk b/openwrt/target/linux/image/tgz.mk
index 6948329..544aeae 100644
--- a/openwrt/target/linux/image/tgz.mk
+++ b/openwrt/target/linux/image/tgz.mk
@@ -1,14 +1,8 @@
-$(KDIR)/vmlinux.gz: $(KDIR)/vmlinux
- gzip -c -vf9 < $< > $@
+$(KDIR)/root.tar.gz:
+ tar -zcf $@ --owner=root --group=root -C $(KDIR)/root/ .
-$(KDIR)/rootfs.tar.gz: $(KDIR)/vmlinux.gz
- tar -cf $(KDIR)/rootfs.tar --owner=root --group=root -C $(KDIR)/ ./vmlinux.gz
- tar -rf $(KDIR)/rootfs.tar --owner=root --group=root -C $(KDIR)/root/ .
- gzip -f9 $(KDIR)/rootfs.tar
-
-tgz-install: $(KDIR)/rootfs.tar.gz
- cp $(KDIR)/vmlinux.gz $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.gz
- cp $(KDIR)/rootfs.tar.gz $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz
+tgz-install: $(KDIR)/root.tar.gz
+ $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="tgz"
prepare:
compile: