summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-12-20 23:17:13 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-12-20 23:17:13 +0000
commitd4609aa51281b567e367ebb4c24119888784c474 (patch)
tree7d93c821e72be9d240f033e961ced89cf4fb98e9 /openwrt/target/linux/image
parent00d1e1af290052c65571f6ae859155bc0a7c09db (diff)
downloadmtk-20170518-d4609aa51281b567e367ebb4c24119888784c474.zip
mtk-20170518-d4609aa51281b567e367ebb4c24119888784c474.tar.gz
mtk-20170518-d4609aa51281b567e367ebb4c24119888784c474.tar.bz2
backport flash-map driver and serial setup from 2.6 for netgear wgt634, split flash map from brcm patch
SVN-Revision: 2744
Diffstat (limited to 'openwrt/target/linux/image')
-rw-r--r--openwrt/target/linux/image/brcm/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/openwrt/target/linux/image/brcm/Makefile b/openwrt/target/linux/image/brcm/Makefile
index e2a8131..01a3cab 100644
--- a/openwrt/target/linux/image/brcm/Makefile
+++ b/openwrt/target/linux/image/brcm/Makefile
@@ -88,10 +88,14 @@ install: $(BIN_DIR)/openwrt-wrt54g-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wr
endif
ifneq ($(FS),jffs2-4MB)
+$(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+ dd if=$(BUILD_DIR)/loader.elf of=$@ bs=131072 conv=sync
+ cat $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx >> $@
+
$(BIN_DIR)/openwrt-wrt54gs-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
$(STAGING_DIR)/bin/addpattern -4 -p W54S -v v4.70.6 -i $< -o $@ -g
-install: $(BIN_DIR)/openwrt-wrt54gs-$(KERNEL)-$(FSNAME).bin
+install: $(BIN_DIR)/openwrt-wrt54gs-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin
endif
$(BIN_DIR)/openwrt-motorola-$(KERNEL)-$(FS).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx