summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-08-13 16:15:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-08-13 16:15:24 +0000
commit5932fa36388c17e8a7814dc4676197922f3799b7 (patch)
tree242ef7b1c29a2792defcd20b5d7553f6a3a852a7 /openwrt/target/linux/image
parenta2300375e426ae3d82ad9587bd17467f52c1294e (diff)
downloadmtk-20170518-5932fa36388c17e8a7814dc4676197922f3799b7.zip
mtk-20170518-5932fa36388c17e8a7814dc4676197922f3799b7.tar.gz
mtk-20170518-5932fa36388c17e8a7814dc4676197922f3799b7.tar.bz2
fix tgz building
SVN-Revision: 1632
Diffstat (limited to 'openwrt/target/linux/image')
-rw-r--r--openwrt/target/linux/image/tgz.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/openwrt/target/linux/image/tgz.mk b/openwrt/target/linux/image/tgz.mk
index 544aeae..756d28b 100644
--- a/openwrt/target/linux/image/tgz.mk
+++ b/openwrt/target/linux/image/tgz.mk
@@ -1,9 +1,14 @@
$(KDIR)/root.tar.gz:
tar -zcf $@ --owner=root --group=root -C $(KDIR)/root/ .
+ifeq ($(BOARD),soekris)
+install: tgz-install
+
tgz-install: $(KDIR)/root.tar.gz
$(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="tgz"
+endif
prepare:
compile:
-install: tgz-install
+install: $(KDIR)/root.tar.gz
+