summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-07-25 15:40:23 +0000
committerNicolas Thill <nico@openwrt.org>2005-07-25 15:40:23 +0000
commit6f4cb7338f84dfe5bf8023ecc020e42c8014ed49 (patch)
tree34fd65e40faad3e94439d9f9ce6552f274d595b1 /openwrt/target/linux/image
parent19abf86c40a8a97e86d5c265f63a80a7b243aa3a (diff)
downloadmtk-20170518-6f4cb7338f84dfe5bf8023ecc020e42c8014ed49.zip
mtk-20170518-6f4cb7338f84dfe5bf8023ecc020e42c8014ed49.tar.gz
mtk-20170518-6f4cb7338f84dfe5bf8023ecc020e42c8014ed49.tar.bz2
add preliminary support for soekris boards
SVN-Revision: 1564
Diffstat (limited to 'openwrt/target/linux/image')
-rw-r--r--openwrt/target/linux/image/Makefile4
-rw-r--r--openwrt/target/linux/image/soekris/Makefile10
2 files changed, 14 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/Makefile b/openwrt/target/linux/image/Makefile
index 73e67a3..6509952 100644
--- a/openwrt/target/linux/image/Makefile
+++ b/openwrt/target/linux/image/Makefile
@@ -14,6 +14,10 @@ ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS_LZMA),y)
include ./squashfs.mk
endif
+ifeq ($(BR2_TARGET_ROOTFS_TGZ),y)
+include ./tgz.mk
+endif
+
prepare:
compile:
install:
diff --git a/openwrt/target/linux/image/soekris/Makefile b/openwrt/target/linux/image/soekris/Makefile
new file mode 100644
index 0000000..bfb2770
--- /dev/null
+++ b/openwrt/target/linux/image/soekris/Makefile
@@ -0,0 +1,10 @@
+include $(TOPDIR)/rules.mk
+
+KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz: $(KDIR)/rootfs.tar.gz
+ cp $^ $@
+
+prepare:
+compile:
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz