summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-08-17 19:47:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-08-17 19:47:34 +0000
commit3c1610a752c7c42fdbc9bcb5404d104c4f9e616f (patch)
tree5bfc92b8640aea580f4a6dab11a59e84fbe34687 /openwrt/target/linux/image
parent52f3b5d7d8cd7ba4dfdb9d27fce9786fc0590624 (diff)
downloadmtk-20170518-3c1610a752c7c42fdbc9bcb5404d104c4f9e616f.zip
mtk-20170518-3c1610a752c7c42fdbc9bcb5404d104c4f9e616f.tar.gz
mtk-20170518-3c1610a752c7c42fdbc9bcb5404d104c4f9e616f.tar.bz2
fix ar7 compile
SVN-Revision: 1691
Diffstat (limited to 'openwrt/target/linux/image')
-rw-r--r--openwrt/target/linux/image/ar7/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/target/linux/image/ar7/Makefile b/openwrt/target/linux/image/ar7/Makefile
index 8a369ed..c6a9045 100644
--- a/openwrt/target/linux/image/ar7/Makefile
+++ b/openwrt/target/linux/image/ar7/Makefile
@@ -38,7 +38,7 @@ $(KDIR)/vmlinux.lzma: $(KDIR)/vmlinux
cat $^ | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $@ || (rm -f $@ && false)
ifeq ($(IB),)
-$(KDIR)/vmlinux.bin: $(KDIR)/vmlinux.lzma
+$(KDIR)/vmlinux.bin: $(KDIR)/vmlinux.lzma compile
$(TARGET_CROSS)ld -T $(PKG_BUILD_DIR)/zimage.script -r -b binary $< -o $(KDIR)/zimage.o
$(TARGET_CROSS)ld -static -G 0 --defsym kernel_entry=$(KERNEL_ENTRY) -T $(PKG_BUILD_DIR)/ld.script \
$(PKG_BUILD_DIR)/loader.o \
@@ -48,7 +48,7 @@ $(KDIR)/vmlinux.bin: $(KDIR)/vmlinux.lzma
$(TARGET_CROSS)objcopy -O srec $(KDIR)/loader $(KDIR)/ram_zimage.sre
$(STAGING_DIR)/bin/srec2bin $(KDIR)/ram_zimage.sre $@
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-kernel.bin: $(KDIR)/vmlinux.bin
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-kernel.bin: $(KDIR)/vmlinux.bin
endif
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-kernel.bin: