summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-25 19:36:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-25 19:36:06 +0000
commit435057887ef62ff0ac8928ef91404757d7bef615 (patch)
treef54d8ab82a3d504b62931d20dfc200f96f0241b2 /openwrt/target/linux/image
parent2c778ce264ea4acf91f00d5d55c115886bfa22ec (diff)
downloadmtk-20170518-435057887ef62ff0ac8928ef91404757d7bef615.zip
mtk-20170518-435057887ef62ff0ac8928ef91404757d7bef615.tar.gz
mtk-20170518-435057887ef62ff0ac8928ef91404757d7bef615.tar.bz2
rename openwrt-ar7-zimage.bin to openwrt-ar7-2.4-kernel.bin
SVN-Revision: 1569
Diffstat (limited to 'openwrt/target/linux/image')
-rw-r--r--openwrt/target/linux/image/ar7/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/openwrt/target/linux/image/ar7/Makefile b/openwrt/target/linux/image/ar7/Makefile
index 6725302..ee2b570 100644
--- a/openwrt/target/linux/image/ar7/Makefile
+++ b/openwrt/target/linux/image/ar7/Makefile
@@ -40,7 +40,7 @@ $(KDIR)/vmlinux.gz: $(KDIR)/vmlinux
$(KDIR)/vmlinux.lzma: $(KDIR)/vmlinux
cat $^ | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $@ || (rm -f $@ && false)
-$(BIN_DIR)/openwrt-ar7-zimage.bin: $(KDIR)/vmlinux.lzma compile
+$(BIN_DIR)/openwrt-ar7-2.4-kernel.bin: $(KDIR)/vmlinux.lzma compile
$(TARGET_CROSS)ld -T $(PKG_BUILD_DIR)/zimage.script -r -b binary $< -o $(KDIR)/zimage.o
$(TARGET_CROSS)ld -static -G 0 --defsym kernel_entry=$(KERNEL_ENTRY) -T $(PKG_BUILD_DIR)/ld.script \
$(PKG_BUILD_DIR)/loader.o \
@@ -57,7 +57,7 @@ ifeq ($(FS),jffs2-4MB)
ALIGN:=bs=65536 conv=sync
endif
-$(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin: $(BIN_DIR)/openwrt-ar7-zimage.bin
+$(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin: $(BIN_DIR)/openwrt-ar7-2.4-kernel.bin
dd if=$< $(ALIGN) > $@
cat $(BUILD_DIR)/linux-$(KERNEL)-ar7/root.$(FS) >> $@
@@ -79,5 +79,5 @@ clean:
prepare: $(PKG_BUILD_DIR) $(PKG_BUILD_DIR)/zimage.script $(PKG_BUILD_DIR)/ld.script
compile: prepare $(PKG_BUILD_DIR)/loader.o $(PKG_BUILD_DIR)/LzmaDecode.o $(PKG_BUILD_DIR)/srec2bin
-install: $(BIN_DIR)/openwrt-ar7-zimage.bin $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin
+install: $(BIN_DIR)/openwrt-ar7-2.4-kernel.bin $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin