summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-08-13 07:33:34 +0000
committerNicolas Thill <nico@openwrt.org>2005-08-13 07:33:34 +0000
commit61c6b8790db8dc5ff65ab4fb7a7f2aa154505132 (patch)
tree4d9adc44c978227ad79424739a5f91a74043b25c /openwrt/target/linux/image
parente29ce276cd2c6fe7c0e6df1739b930e89c13b038 (diff)
downloadmtk-20170518-61c6b8790db8dc5ff65ab4fb7a7f2aa154505132.zip
mtk-20170518-61c6b8790db8dc5ff65ab4fb7a7f2aa154505132.tar.gz
mtk-20170518-61c6b8790db8dc5ff65ab4fb7a7f2aa154505132.tar.bz2
build jffs2 image too since it works with CF and MTD block emulation
SVN-Revision: 1618
Diffstat (limited to 'openwrt/target/linux/image')
-rw-r--r--openwrt/target/linux/image/soekris/Makefile27
1 files changed, 25 insertions, 2 deletions
diff --git a/openwrt/target/linux/image/soekris/Makefile b/openwrt/target/linux/image/soekris/Makefile
index bfb2770..0b4fba9 100644
--- a/openwrt/target/linux/image/soekris/Makefile
+++ b/openwrt/target/linux/image/soekris/Makefile
@@ -2,9 +2,32 @@ include $(TOPDIR)/rules.mk
KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz: $(KDIR)/rootfs.tar.gz
+
+ifeq ($(FS),jffs2-8MB)
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img: $(KDIR)/root.$(FS)
cp $^ $@
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
+
+endif
+
+
+ifeq ($(FS),tgz)
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz: $(KDIR)/root.tar.gz
+ cp $^ $@
+
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz
+
+endif
+
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz: $(KDIR)/bzImage
+ cp $^ $@
+
+
prepare:
compile:
-install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
+