summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/linux-2.4/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-05-30 22:46:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-05-30 22:46:44 +0000
commitcd94ce2d108199a281e9cac009b03ff9e4e456e9 (patch)
tree4b503968543279252d859a1469f4002c4c092c30 /openwrt/target/linux/linux-2.4/Makefile
parentf7c678437027e96f8dfa508b0cc65215e75f1952 (diff)
downloadmtk-20170518-cd94ce2d108199a281e9cac009b03ff9e4e456e9.zip
mtk-20170518-cd94ce2d108199a281e9cac009b03ff9e4e456e9.tar.gz
mtk-20170518-cd94ce2d108199a281e9cac009b03ff9e4e456e9.tar.bz2
split kernel patches into board dependend and generic
SVN-Revision: 1122
Diffstat (limited to 'openwrt/target/linux/linux-2.4/Makefile')
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index 263339f..af06b11 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -169,7 +169,8 @@ $(LINUX_DIR)/.unpacked: $(DL_DIR)/$(LINUX_SOURCE) $(DL_DIR)/$(LINUX_BINARY_WL_DR
touch $(LINUX_DIR)/.unpacked
$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
- $(PATCH) $(LINUX_DIR) ./patches
+ [ -d ./patches/$(BOARD) ] && $(PATCH) $(LINUX_DIR) ./patches/$(BOARD)
+ $(PATCH) $(LINUX_DIR) ./patches/generic
touch $(LINUX_DIR)/.patched
$(LINUX_DIR)/.configured: $(LINUX_DIR)/.patched