summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/linux-2.4/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-11-15 08:23:42 +0000
committerNicolas Thill <nico@openwrt.org>2005-11-15 08:23:42 +0000
commit5de370fbe29d3d20ca8a79b5b61045d3c5cdc375 (patch)
tree0ee77f7a883d9ededfefc2ee872ac4a20eba5e7c /openwrt/target/linux/linux-2.4/Makefile
parent15e214dd89dea138ee1c976aa1bbef1f72217c7e (diff)
downloadmtk-20170518-5de370fbe29d3d20ca8a79b5b61045d3c5cdc375.zip
mtk-20170518-5de370fbe29d3d20ca8a79b5b61045d3c5cdc375.tar.gz
mtk-20170518-5de370fbe29d3d20ca8a79b5b61045d3c5cdc375.tar.bz2
fix kernel package and kernel modules dependency on it
SVN-Revision: 2492
Diffstat (limited to 'openwrt/target/linux/linux-2.4/Makefile')
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index d487446..3982896 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -426,8 +426,7 @@ $(TARGET_MODULES_DIR):
$(KERNEL_IPKG):
rm -rf $(KERNEL_IDIR)
mkdir -p $(KERNEL_IDIR)/etc
- $(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(PKG_RELEASE) $(ARCH)
- echo 'Package: kernel-$(LINUX_VERSION)-$(BOARD)' >> $(KERNEL_IDIR)/CONTROL/control
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE) $(ARCH)
if [ -f ./config/$(BOARD).modules ]; then \
cp ./config/$(BOARD).modules $(KERNEL_IDIR)/etc/modules; \
fi