summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/linux-2.4/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-06-05 14:42:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-06-05 14:42:57 +0000
commit981d0433773f67b9d233a57e6f6a8acd9e5798d3 (patch)
tree0b0107939b9ea5f786dba8529dac1f60cca77ecd /openwrt/target/linux/linux-2.4/Makefile
parent63dab52461925d107ba9681aa0f9a5292f83e924 (diff)
downloadmtk-20170518-981d0433773f67b9d233a57e6f6a8acd9e5798d3.zip
mtk-20170518-981d0433773f67b9d233a57e6f6a8acd9e5798d3.tar.gz
mtk-20170518-981d0433773f67b9d233a57e6f6a8acd9e5798d3.tar.bz2
add rebuild target for the linux directory
SVN-Revision: 1149
Diffstat (limited to 'openwrt/target/linux/linux-2.4/Makefile')
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index 08e91da..9a594b7 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -213,6 +213,8 @@ $(TARGET_MODULES_DIR):
source: $(DL_DIR)/$(LINUX_SOURCE)
prepare: $(LINUX_DIR)/.configured
compile: $(LINUX_DIR)/.modules_done $(TARGETS)
+ rm -f $(LINUX_DIR)
+ ln -s $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) $(LINUX_DIR)
$(MAKE) -C $(TOPDIR)/target/linux/package \
TARGET_DIR="$(LINUX_TARGET_DIR)" \
BUILD_DIR="$(LINUX_BUILD_DIR)" \
@@ -225,6 +227,18 @@ install: compile $(TARGET_MODULES_DIR)
echo -e 'dest root /\noption offline_root $(LINUX_BUILD_DIR)/root' > $(LINUX_BUILD_DIR)/ipkg.conf
[ "$(INSTALL_TARGETS)" != "" ] && $(IPKG_KERNEL) install $(INSTALL_TARGETS) || true
+mostlyclean:
+ rm -f $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION)/.{drivers-unpacked,modules_done}
+ $(MAKE) -C $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) clean
+ rm -f $(LINUX_KERNEL) $(LINUX_IMAGE)
+
+rebuild:
+ -$(MAKE) mostlyclean
+ if [ -f $(LINUX_KERNEL) ]; then \
+ $(MAKE) clean; \
+ fi
+ $(MAKE) compile
+
clean:
rm -rf $(LINUX_BUILD_DIR)
rm -f $(TARGETS)