summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/linux-2.4/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-06-05 22:21:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-06-05 22:21:27 +0000
commit371b05f52e7815239df08911564e01f0bf726b2b (patch)
tree89c34815539a443f198c3d555be0390f8d13e16b /openwrt/target/linux/linux-2.4/Makefile
parent52d8a80daf072f0ae0ec43db1afbe144a4a36908 (diff)
downloadmtk-20170518-371b05f52e7815239df08911564e01f0bf726b2b.zip
mtk-20170518-371b05f52e7815239df08911564e01f0bf726b2b.tar.gz
mtk-20170518-371b05f52e7815239df08911564e01f0bf726b2b.tar.bz2
fix linux kernel build
SVN-Revision: 1157
Diffstat (limited to 'openwrt/target/linux/linux-2.4/Makefile')
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index 9a594b7..0c9021b 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -213,8 +213,7 @@ $(TARGET_MODULES_DIR):
source: $(DL_DIR)/$(LINUX_SOURCE)
prepare: $(LINUX_DIR)/.configured
compile: $(LINUX_DIR)/.modules_done $(TARGETS)
- rm -f $(LINUX_DIR)
- ln -s $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) $(LINUX_DIR)
+ ln -sf $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) $(LINUX_DIR)
$(MAKE) -C $(TOPDIR)/target/linux/package \
TARGET_DIR="$(LINUX_TARGET_DIR)" \
BUILD_DIR="$(LINUX_BUILD_DIR)" \