summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/linux-2.4
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-11-11 13:40:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-11-11 13:40:51 +0000
commit51590a03b5dffbe004852edfd76d06ac94701110 (patch)
tree76ec3eed78b5df0a4f57036b7a1e6b524c4d09e2 /openwrt/target/linux/linux-2.4
parente88d0d4035f8db44680c0d9cb363a2f11da3c6aa (diff)
downloadmtk-20170518-51590a03b5dffbe004852edfd76d06ac94701110.zip
mtk-20170518-51590a03b5dffbe004852edfd76d06ac94701110.tar.gz
mtk-20170518-51590a03b5dffbe004852edfd76d06ac94701110.tar.bz2
extend mkdep fix (fixes #36)
SVN-Revision: 2414
Diffstat (limited to 'openwrt/target/linux/linux-2.4')
-rw-r--r--openwrt/target/linux/linux-2.4/patches/generic/209-mkdep_fix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/openwrt/target/linux/linux-2.4/patches/generic/209-mkdep_fix.patch b/openwrt/target/linux/linux-2.4/patches/generic/209-mkdep_fix.patch
index c1e18a0..a43d1d2 100644
--- a/openwrt/target/linux/linux-2.4/patches/generic/209-mkdep_fix.patch
+++ b/openwrt/target/linux/linux-2.4/patches/generic/209-mkdep_fix.patch
@@ -9,3 +9,14 @@
ifdef ALL_SUB_DIRS
$(MAKE) $(patsubst %,_sfdep_%,$(ALL_SUB_DIRS)) _FASTDEP_ALL_SUB_DIRS="$(ALL_SUB_DIRS)"
endif
+--- linux-2.4.30/Makefile.old 2005-11-11 14:27:55.878482250 +0100
++++ linux-2.4.30/Makefile 2005-11-11 14:28:57.926360000 +0100
+@@ -509,7 +509,7 @@
+ ifdef CONFIG_MODVERSIONS
+ $(MAKE) update-modverfile
+ endif
+- scripts/mkdep -- `find $(FINDHPATH) \( -name SCCS -o -name .svn \) -prune -o -follow -name \*.h ! -name modversions.h -print` > .hdepend
++ find $(FINDHPATH) \( -name SCCS -o -name .svn \) -prune -o -follow -name \*.h ! -name modversions.h -print | xargs scripts/mkdep -- > .hdepend
+ scripts/mkdep -- init/*.c > .depend
+
+ ifdef CONFIG_MODVERSIONS