summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/linux-2.6/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 14:37:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 14:37:56 +0000
commit83c7321d6dff698a09c64f3d3caabea6cd29a484 (patch)
tree0f1d795bedeb36d9032b4c7e8b73e4debde73173 /openwrt/target/linux/linux-2.6/Makefile
parent88568daa2ae1cf0e86b23814f9952e598e61286a (diff)
downloadmtk-20170518-83c7321d6dff698a09c64f3d3caabea6cd29a484.zip
mtk-20170518-83c7321d6dff698a09c64f3d3caabea6cd29a484.tar.gz
mtk-20170518-83c7321d6dff698a09c64f3d3caabea6cd29a484.tar.bz2
fix unnecessary recompiling of packages
SVN-Revision: 2239
Diffstat (limited to 'openwrt/target/linux/linux-2.6/Makefile')
-rw-r--r--openwrt/target/linux/linux-2.6/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/openwrt/target/linux/linux-2.6/Makefile b/openwrt/target/linux/linux-2.6/Makefile
index 7c25475..9ff3ed7 100644
--- a/openwrt/target/linux/linux-2.6/Makefile
+++ b/openwrt/target/linux/linux-2.6/Makefile
@@ -235,6 +235,11 @@ $(KERNEL_IPKG):
$(STAMP_DIR)/.linux-compile: $(LINUX_DIR)/.modules_done
@mkdir -p $(STAMP_DIR)
@$(MAKE) $(TARGETS)
+ ln -sf $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) $(LINUX_DIR)
+ @$(TRACE) target/linux/package
+ $(MAKE) -C $(TOPDIR)/target/linux/package \
+ $(KPKG_MAKEOPTS) \
+ compile
touch $@
source: $(DL_DIR)/$(LINUX_SOURCE)
@@ -242,11 +247,6 @@ prepare: $(LINUX_DIR)/.configured
compile:
@$(PKG_TRACE) Compiling...
$(MAKE) $(STAMP_DIR)/.linux-compile $(MAKE_TRACE)
- ln -sf $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) $(LINUX_DIR)
- @$(TRACE) target/linux/package
- $(MAKE) -C $(TOPDIR)/target/linux/package \
- $(KPKG_MAKEOPTS) \
- compile
install: compile $(TARGET_MODULES_DIR) $(KERNEL_IPKG)
rm -rf $(LINUX_BUILD_DIR)/root*