summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-05-28 10:54:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-05-28 10:54:32 +0000
commitc1d1cf837633d4804e06a0168acc7fd73fc2a18e (patch)
treeb42cc4126a0471e50bd8b982009d2466e7b53d73 /openwrt/target/linux/package/Makefile
parent0f13231ccbc3d35e0118ef6bd52097c6ec9024d2 (diff)
downloadmtk-20170518-c1d1cf837633d4804e06a0168acc7fd73fc2a18e.zip
mtk-20170518-c1d1cf837633d4804e06a0168acc7fd73fc2a18e.tar.gz
mtk-20170518-c1d1cf837633d4804e06a0168acc7fd73fc2a18e.tar.bz2
fix wlcompat build
SVN-Revision: 1087
Diffstat (limited to 'openwrt/target/linux/package/Makefile')
-rw-r--r--openwrt/target/linux/package/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/openwrt/target/linux/package/Makefile b/openwrt/target/linux/package/Makefile
index 868400d..055bd2f 100644
--- a/openwrt/target/linux/package/Makefile
+++ b/openwrt/target/linux/package/Makefile
@@ -4,6 +4,9 @@ include $(TOPDIR)/rules.mk
package-$(BR2_PACKAGE_KMOD_FUSE) += fuse
package-$(BR2_PACKAGE_KMOD_SHFS) += shfs
package-$(BR2_PACKAGE_KMOD_OPENSWAN) += openswan
+ifeq ($(LINUX_VERSION),2.4.30)
+package-$(BR2_PACKAGE_KMOD_WLCOMPAT) += wlcompat
+endif
all: compile install
clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
@@ -12,6 +15,7 @@ install: $(patsubst %,%-install,$(package-y))
%-prepare:
$(MAKE) -C $(patsubst %-prepare,%,$@) \
+ TARGET_DIR="$(TARGET_DIR)" \
BUILD_DIR="$(BUILD_DIR)" \
KERNEL_DIR="$(KERNEL_DIR)" \
LINUX_VERSION="$(LINUX_VERSION)" \
@@ -19,6 +23,7 @@ install: $(patsubst %,%-install,$(package-y))
%-compile: %-prepare
$(MAKE) -C $(patsubst %-compile,%,$@) \
+ TARGET_DIR="$(TARGET_DIR)" \
BUILD_DIR="$(BUILD_DIR)" \
KERNEL_DIR="$(KERNEL_DIR)" \
LINUX_VERSION="$(LINUX_VERSION)" \
@@ -26,6 +31,7 @@ install: $(patsubst %,%-install,$(package-y))
%-install: %-compile
$(MAKE) -C $(patsubst %-install,%,$@) \
+ TARGET_DIR="$(TARGET_DIR)" \
BUILD_DIR="$(BUILD_DIR)" \
KERNEL_DIR="$(KERNEL_DIR)" \
LINUX_VERSION="$(LINUX_VERSION)" \