summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/package/alsa
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-01-10 19:43:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-01-10 19:43:00 +0000
commitea35a1edbebfa01ee51e625e670a65fa985fc1b5 (patch)
treedbdaf951693481c46030073d2fe14fe6b87b2d88 /openwrt/target/linux/package/alsa
parent60cc7e45d753052032679a2ce4f4e323ee1da8f6 (diff)
downloadmtk-20170518-ea35a1edbebfa01ee51e625e670a65fa985fc1b5.zip
mtk-20170518-ea35a1edbebfa01ee51e625e670a65fa985fc1b5.tar.gz
mtk-20170518-ea35a1edbebfa01ee51e625e670a65fa985fc1b5.tar.bz2
large target/linux cleanup
SVN-Revision: 2877
Diffstat (limited to 'openwrt/target/linux/package/alsa')
-rw-r--r--openwrt/target/linux/package/alsa/Config.in4
-rw-r--r--openwrt/target/linux/package/alsa/Makefile14
2 files changed, 7 insertions, 11 deletions
diff --git a/openwrt/target/linux/package/alsa/Config.in b/openwrt/target/linux/package/alsa/Config.in
index 29a4e89..df4da0b 100644
--- a/openwrt/target/linux/package/alsa/Config.in
+++ b/openwrt/target/linux/package/alsa/Config.in
@@ -1,9 +1,9 @@
config BR2_PACKAGE_KMOD_ALSA
prompt "kmod-alsa......................... Alsa Sound Drivers"
tristate
- default m if CONFIG_DEVEL
- depends BR2_LINUX_2_4_X86 || BR2_LINUX_2_4_BRCM || BR2_LINUX_2_6_X86 || BR2_LINUX_2_6_BRCM
+ depends BR2_LINUX_2_4_X86 || BR2_LINUX_2_4_BRCM || BR2_LINUX_2_6_X86 || BR2_LINUX_2_6_BRCM
depends BR2_PACKAGE_KMOD_USB_CONTROLLER
select BR2_PACKAGE_KMOD_SOUNDCORE
+ default m if CONFIG_DEVEL
help
Alsa Drivers for USB Soundcards
diff --git a/openwrt/target/linux/package/alsa/Makefile b/openwrt/target/linux/package/alsa/Makefile
index 02baa44..711ee1f 100644
--- a/openwrt/target/linux/package/alsa/Makefile
+++ b/openwrt/target/linux/package/alsa/Makefile
@@ -14,29 +14,25 @@ PKG_CAT:=bzcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-ifeq ($(KERNEL_DIR),)
-KERNEL_DIR:=$(LINUX_DIR)
-endif
-
include $(TOPDIR)/package/rules.mk
ifeq ($(LINUX_KARCH),i386)
-KERNEL_C_INCS:= -I$(KERNEL_DIR)/include/asm-i386/mach-generic
+KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-i386/mach-generic
KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
endif
ifeq ($(LINUX_KARCH),mips)
-KERNEL_C_INCS:= -I$(KERNEL_DIR)/include/asm-mips/mach-generic
+KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-mips/mach-generic
KERNEL_C_OPTS:= -Os -G 0 -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
endif
-$(eval $(call PKG_template,KMOD_ALSA,kmod-alsa,$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE),$(ARCH),kernel-$(LINUX_VERSION)-$(BOARD) ($(KERNEL_RELEASE))))
+$(eval $(call PKG_template,KMOD_ALSA,kmod-alsa,$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE),$(ARCH),kernel-$(LINUX_VERSION)-$(BOARD) ($(LINUX_RELEASE))))
$(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); \
CFLAGS="$(KERNEL_C_INCS)" \
./configure \
- --with-build=$(KERNEL_DIR) \
- --with-kernel=$(KERNEL_DIR) \
+ --with-build=$(LINUX_DIR) \
+ --with-kernel=$(LINUX_DIR) \
--with-cross=$(KERNEL_CROSS) \
--with-redhat=no \
--with-suse=no \