summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/package/ieee80211-dscape
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-01-10 19:43:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-01-10 19:43:00 +0000
commitea35a1edbebfa01ee51e625e670a65fa985fc1b5 (patch)
treedbdaf951693481c46030073d2fe14fe6b87b2d88 /openwrt/target/linux/package/ieee80211-dscape
parent60cc7e45d753052032679a2ce4f4e323ee1da8f6 (diff)
downloadmtk-20170518-ea35a1edbebfa01ee51e625e670a65fa985fc1b5.zip
mtk-20170518-ea35a1edbebfa01ee51e625e670a65fa985fc1b5.tar.gz
mtk-20170518-ea35a1edbebfa01ee51e625e670a65fa985fc1b5.tar.bz2
large target/linux cleanup
SVN-Revision: 2877
Diffstat (limited to 'openwrt/target/linux/package/ieee80211-dscape')
-rw-r--r--openwrt/target/linux/package/ieee80211-dscape/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/openwrt/target/linux/package/ieee80211-dscape/Makefile b/openwrt/target/linux/package/ieee80211-dscape/Makefile
index 90d55b3..90fe09d 100644
--- a/openwrt/target/linux/package/ieee80211-dscape/Makefile
+++ b/openwrt/target/linux/package/ieee80211-dscape/Makefile
@@ -9,12 +9,7 @@ PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
include $(TOPDIR)/package/rules.mk
-$(eval $(call PKG_template,KMOD_IEEE80211_DSCAPE,$(PKG_NAME),$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(KERNEL_RELEASE))))
-
-ifeq ($(KERNEL_DIR),)
-KERNEL_DIR:=$(LINUX_DIR)
-endif
-KERNEL_VERSION=$(shell echo "$(LINUX_VERSION)" | cut -d. -f1,2)
+$(eval $(call PKG_template,KMOD_IEEE80211_DSCAPE,$(PKG_NAME),$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE))))
$(PKG_BUILD_DIR)/.prepared:
mkdir -p $(PKG_BUILD_DIR)
@@ -25,12 +20,12 @@ $(PKG_BUILD_DIR)/.configured:
touch $@
$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C "$(KERNEL_DIR)" \
+ $(MAKE) -C "$(LINUX_DIR)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
ARCH="$(LINUX_KARCH)" \
PATH="$(TARGET_PATH)" \
SUBDIRS="$(PKG_BUILD_DIR)" \
- LINUXINCLUDE="-I$(shell pwd)/src/include -I$(KERNEL_DIR)/include" \
+ LINUXINCLUDE="-I$(shell pwd)/src/include -I$(LINUX_DIR)/include" \
modules
touch $@