summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 00:06:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 00:06:20 +0000
commit35d1297447cc2d8cf4c1037079beafe876094b87 (patch)
treeabaa34bdde876fc22b783aa1c3c445615ac50b75 /openwrt/target/linux/package
parent196076cf2f58b0239a2a9df7d2b09274d23b81ec (diff)
downloadmtk-20170518-35d1297447cc2d8cf4c1037079beafe876094b87.zip
mtk-20170518-35d1297447cc2d8cf4c1037079beafe876094b87.tar.gz
mtk-20170518-35d1297447cc2d8cf4c1037079beafe876094b87.tar.bz2
large build system cleanup. added some stuff to control the verbosity level, but not complete, yet.
SVN-Revision: 2221
Diffstat (limited to 'openwrt/target/linux/package')
-rw-r--r--openwrt/target/linux/package/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/openwrt/target/linux/package/Makefile b/openwrt/target/linux/package/Makefile
index 7e8588d..6b7a858 100644
--- a/openwrt/target/linux/package/Makefile
+++ b/openwrt/target/linux/package/Makefile
@@ -34,20 +34,24 @@ MAKEOPTS:= BOARD="$(BOARD)" \
%-prepare:
+ @$(TRACE) target/linux/package/$(patsubst %-prepare,%,$@)-prepare
$(MAKE) -C $(patsubst %-prepare,%,$@) \
$(MAKEOPTS) \
prepare
%-compile: %-prepare
+ @$(TRACE) target/linux/package/$(patsubst %-compile,%,$@)-compile
$(MAKE) -C $(patsubst %-compile,%,$@) \
$(MAKEOPTS) \
compile
%-install: %-compile
+ @$(TRACE) target/linux/package/$(patsubst %-install,%,$@)-install
$(MAKE) -C $(patsubst %-install,%,$@) \
$(MAKEOPTS) \
install
%-clean:
+ @$(TRACE) target/linux/package/$(patsubst %-clean,%,$@)-clean
@$(MAKE) -C $(patsubst %-clean,%,$@) clean