summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-01-17 15:45:36 +0000
committerNicolas Thill <nico@openwrt.org>2006-01-17 15:45:36 +0000
commit66477433896176b00dda28968683608a1ce41ad0 (patch)
tree1b997f80193bc026d720902ac9706d878ad0ce1e /openwrt/target/linux/package
parentc0ab7f7b2f0c59993c8d81711c2f681df52ae098 (diff)
downloadmtk-20170518-66477433896176b00dda28968683608a1ce41ad0.zip
mtk-20170518-66477433896176b00dda28968683608a1ce41ad0.tar.gz
mtk-20170518-66477433896176b00dda28968683608a1ce41ad0.tar.bz2
add a patch to export various kernel symbols in lib/string.c (like in 2.6), fix shfs build on 2.4 (hopefully, but no real tests yet)
SVN-Revision: 3004
Diffstat (limited to 'openwrt/target/linux/package')
-rw-r--r--openwrt/target/linux/package/shfs/patches/101-kmod_build.patch9
1 files changed, 2 insertions, 7 deletions
diff --git a/openwrt/target/linux/package/shfs/patches/101-kmod_build.patch b/openwrt/target/linux/package/shfs/patches/101-kmod_build.patch
index 6359004..1170103 100644
--- a/openwrt/target/linux/package/shfs/patches/101-kmod_build.patch
+++ b/openwrt/target/linux/package/shfs/patches/101-kmod_build.patch
@@ -1,6 +1,6 @@
--- shfs-0.35-orig/shfs/Linux-2.4/Makefile 2004-06-01 15:16:19.000000000 +0200
+++ shfs-0.35-2/shfs/Linux-2.4/Makefile 2005-04-09 02:34:35.000000000 +0200
-@@ -1,3 +1,17 @@
+@@ -1,3 +1,13 @@
+#
+# the original Makefile was trashed and replaced by this one
+# The main reason is that loadable modules should be built with
@@ -10,15 +10,11 @@
+# make -C $(KERNEL_DIR) SUBDIRS="$(shell pwd)" modules
+# make -C $(KERNEL_DIR) SUBDIRS="$(shell pwd)" modules_install
+#
-+#
-+# $(TOPDIR)/lib/string.o is needed at link time because the memchr function
-+# is not exported on mips (insmod: unresolved symbol memchr)
-+#
+
ifndef KERNEL
KERNEL=$(shell uname -r)
endif
-@@ -10,67 +24,30 @@
+@@ -10,67 +24,29 @@
KERNEL_SOURCES=${MODULESDIR}/build
endif
@@ -99,5 +95,4 @@
+ rm -f core *.o *.a *.s
+
+shfs.o: $(shfs-objs)
-+ $(LD) -r -o $@ $(shfs-objs) $(TOPDIR)/lib/string.o
+