summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/rules.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-11-01 17:30:26 +0000
committerNicolas Thill <nico@openwrt.org>2005-11-01 17:30:26 +0000
commitea72d399efdfd968036ed9b6b0db60a5d29091c7 (patch)
tree74c9b56f253cf6908bf693451b56dbe3158fd6e0 /openwrt/target/linux/rules.mk
parent8c5db04639aa510ba72534accb43c4bf3a407bf5 (diff)
downloadmtk-20170518-ea72d399efdfd968036ed9b6b0db60a5d29091c7.zip
mtk-20170518-ea72d399efdfd968036ed9b6b0db60a5d29091c7.tar.gz
mtk-20170518-ea72d399efdfd968036ed9b6b0db60a5d29091c7.tar.bz2
fix 2.6 modules pattern using a common LINUX_KMOD_SUFFIX variable, fix alsa 2.6 build when arch != mipsel
SVN-Revision: 2311
Diffstat (limited to 'openwrt/target/linux/rules.mk')
-rw-r--r--openwrt/target/linux/rules.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/openwrt/target/linux/rules.mk b/openwrt/target/linux/rules.mk
index 2c0fa09..f7e1086 100644
--- a/openwrt/target/linux/rules.mk
+++ b/openwrt/target/linux/rules.mk
@@ -4,6 +4,11 @@ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
-e 's/sh[234]/sh/' \
)
+ifeq ($(KERNEL),2.6)
+LINUX_KMOD_SUFFIX=ko
+else
+LINUX_KMOD_SUFFIX=o
+endif
define KMOD_template
ifeq ($$(strip $(4)),)