summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-16 09:49:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-16 09:49:24 +0000
commit6e6a04539395c2f22b4f8d43404b40aeefba739a (patch)
tree96d25d6a70fd2bad1598acccc950281bfd405cd4 /openwrt/target/linux/rules.mk
parent7a8db50bd56c5fbe26f3440bdbcbd5fe31eb9d7c (diff)
downloadmtk-20170518-6e6a04539395c2f22b4f8d43404b40aeefba739a.zip
mtk-20170518-6e6a04539395c2f22b4f8d43404b40aeefba739a.tar.gz
mtk-20170518-6e6a04539395c2f22b4f8d43404b40aeefba739a.tar.bz2
add modules.d to kernel modules
SVN-Revision: 1454
Diffstat (limited to 'openwrt/target/linux/rules.mk')
-rw-r--r--openwrt/target/linux/rules.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/openwrt/target/linux/rules.mk b/openwrt/target/linux/rules.mk
index 82ac46d..39afadb 100644
--- a/openwrt/target/linux/rules.mk
+++ b/openwrt/target/linux/rules.mk
@@ -29,7 +29,13 @@ $$(PKG_$(1)): $(LINUX_DIR)/.modules_done
$(SCRIPT_DIR)/make-ipkg-dir.sh $$(I_$(1)) ../control/kmod-$(2).control $(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE) $(ARCH)
echo "Depends: $$(IDEPEND_$(1))" >> $$(I_$(1))/CONTROL/control
cp $(3) $$(I_$(1))/lib/modules/$(LINUX_VERSION)
- $(6)
+ifneq ($(6),)
+ mkdir -p $$(I_$(1))/etc/modules.d
+ for module in $(7); do \
+ echo $$$$module >> $$(I_$(1))/etc/modules.d/$(6)-$(2); \
+ done
+endif
+ $(8)
$(IPKG_BUILD) $$(I_$(1)) $(PACKAGE_DIR)
endef