summaryrefslogtreecommitdiff
path: root/openwrt/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-04 21:57:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-04 21:57:38 +0000
commit2b7eb78d8088f6fae439bb3f060b5183fba043da (patch)
tree0a45bb3077bbf48d0000a3da2f753c2663a44eab /openwrt/target/linux
parent1354f27bbb1e901a66432c0a608eb90f599b29bc (diff)
downloadmtk-20170518-2b7eb78d8088f6fae439bb3f060b5183fba043da.zip
mtk-20170518-2b7eb78d8088f6fae439bb3f060b5183fba043da.tar.gz
mtk-20170518-2b7eb78d8088f6fae439bb3f060b5183fba043da.tar.bz2
fix unnecessary kernel rebuild
SVN-Revision: 3904
Diffstat (limited to 'openwrt/target/linux')
-rw-r--r--openwrt/target/linux/au1000-2.6/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/openwrt/target/linux/au1000-2.6/Makefile b/openwrt/target/linux/au1000-2.6/Makefile
index 8ba22aa..34d4dda 100644
--- a/openwrt/target/linux/au1000-2.6/Makefile
+++ b/openwrt/target/linux/au1000-2.6/Makefile
@@ -17,10 +17,9 @@ $(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
@$(CP) config $(LINUX_DIR)/.config
touch $@
-$(LINUX_BUILD_DIR)/zImage.flash.srec: $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec
- $(MAKE) -C $(LINUX_DIR) V=1 CROSS_COMPILE=$(TARGET_CROSS) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) zImage.flash
+$(LINUX_BUILD_DIR)/zImage.flash.srec: $(LINUX_DIR)/vmlinux
$(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
$(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
touch $@
-compile: $(LINUX_DIR)/vmlinux
+compile: $(LINUX_BUILD_DIR)/zImage.flash.srec