summaryrefslogtreecommitdiff
path: root/openwrt/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-13 23:25:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-13 23:25:24 +0000
commit2d85d1932bcfaa205096e0307c95474036f7e649 (patch)
tree5e92acee49e712c3fae4b5d05c6525baa0902414 /openwrt/target/linux
parent2690a2aedd668b8daba479a681ca67f713b974cd (diff)
downloadmtk-20170518-2d85d1932bcfaa205096e0307c95474036f7e649.zip
mtk-20170518-2d85d1932bcfaa205096e0307c95474036f7e649.tar.gz
mtk-20170518-2d85d1932bcfaa205096e0307c95474036f7e649.tar.bz2
hopefully the last fix for the aruba image stuff
SVN-Revision: 3942
Diffstat (limited to 'openwrt/target/linux')
-rw-r--r--openwrt/target/linux/image/aruba/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/openwrt/target/linux/image/aruba/Makefile b/openwrt/target/linux/image/aruba/Makefile
index d68084b..c8dab05 100644
--- a/openwrt/target/linux/image/aruba/Makefile
+++ b/openwrt/target/linux/image/aruba/Makefile
@@ -23,13 +23,15 @@ define Image/BuildKernel
./addVersion -n ArubaOS $(KDIR)/loader.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari version
endef
-ifeq ($(1),jffs2-64k)
-define Image/Build
+define Image/Build/jffs2-64k
@dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=655360 conv=sync
@cat $(KDIR)/root.$(1) >> $(KDIR)/image.tmp
@dd if=$(KDIR)/image.tmp of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(patsubst jffs2-%,jffs2,$(1)).bin bs=3604480 conv=sync
@rm -f $(KDIR)/image.tmp
endef
-endif
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
$(eval $(call BuildImage))