summaryrefslogtreecommitdiff
path: root/openwrt/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-31 23:29:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-31 23:29:05 +0000
commit9ba9373d546ff96369d03dcf2d92486dbf7f3d26 (patch)
treecd46b0bc66c1e5df3afb9975edd6dcbd841d4be9 /openwrt/target/linux
parent00b53c7433a39b169c54a8da50c580d63cf798ca (diff)
downloadmtk-20170518-9ba9373d546ff96369d03dcf2d92486dbf7f3d26.zip
mtk-20170518-9ba9373d546ff96369d03dcf2d92486dbf7f3d26.tar.gz
mtk-20170518-9ba9373d546ff96369d03dcf2d92486dbf7f3d26.tar.bz2
cleanup; replace .PHONY with FORCE; disable gdb by default
SVN-Revision: 3877
Diffstat (limited to 'openwrt/target/linux')
-rw-r--r--openwrt/target/linux/ar7-2.4/Makefile2
-rw-r--r--openwrt/target/linux/brcm-2.4/Makefile2
-rw-r--r--openwrt/target/linux/image/Makefile16
-rw-r--r--openwrt/target/linux/image/aruba/Makefile4
-rw-r--r--openwrt/target/linux/image/au1000/Makefile4
-rw-r--r--openwrt/target/linux/image/brcm/Makefile4
-rw-r--r--openwrt/target/linux/image/jffs2.mk8
-rw-r--r--openwrt/target/linux/image/jffs2/Makefile2
-rw-r--r--openwrt/target/linux/image/squashfs.mk6
-rw-r--r--openwrt/target/linux/image/squashfs/Makefile2
-rw-r--r--openwrt/target/linux/image/tgz.mk2
-rw-r--r--openwrt/target/linux/image/x86/Makefile7
-rw-r--r--openwrt/target/linux/image/xscale/Makefile8
-rw-r--r--openwrt/target/linux/imagebuilder/Makefile4
-rw-r--r--openwrt/target/linux/kernel.mk11
-rw-r--r--openwrt/target/linux/package/Makefile8
16 files changed, 37 insertions, 53 deletions
diff --git a/openwrt/target/linux/ar7-2.4/Makefile b/openwrt/target/linux/ar7-2.4/Makefile
index 207d95d..7775e88 100644
--- a/openwrt/target/linux/ar7-2.4/Makefile
+++ b/openwrt/target/linux/ar7-2.4/Makefile
@@ -60,7 +60,7 @@ $(LINUX_DIR)/.drivers-unpacked: $(LINUX_DIR)/.unpacked
linux-dirclean: drivers-clean
-drivers-clean:
+drivers-clean: FORCE
rm -rf $(BUILD_DIR)/$(ATM_FIRMWARE_DIR)
diff --git a/openwrt/target/linux/brcm-2.4/Makefile b/openwrt/target/linux/brcm-2.4/Makefile
index 9447114..384a1ea 100644
--- a/openwrt/target/linux/brcm-2.4/Makefile
+++ b/openwrt/target/linux/brcm-2.4/Makefile
@@ -62,5 +62,5 @@ $(LINUX_DIR)/.drivers-installed: $(LINUX_DIR)/.modules_done
linux-dirclean: drivers-clean
-drivers-clean:
+drivers-clean: FORCE
rm -rf $(BUILD_DIR)/kernel-binary-wl
diff --git a/openwrt/target/linux/image/Makefile b/openwrt/target/linux/image/Makefile
index 3b82343..a5141cb 100644
--- a/openwrt/target/linux/image/Makefile
+++ b/openwrt/target/linux/image/Makefile
@@ -14,25 +14,23 @@ ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
include ./tgz.mk
endif
-prepare:
+prepare: FORCE
$(MAKE) prepare-targets
-compile:
+compile: FORCE
$(MAKE) compile-targets
-install:
+install: FORCE
$(MAKE) install-targets
-.PHONY: prepare compile install
-
-$(BOARD)-compile:
+$(BOARD)-compile: FORCE
$(MAKE) -C $(BOARD) prepare
$(MAKE) -C $(BOARD) compile
-install-ib:
+install-ib: FORCE
-$(MAKE) -C $(BOARD) IB_DIR="$(IB_DIR)" install-ib
mkdir -p $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)
$(CP) $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/kernel[-_]*.ipk $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)/
-install-prepare:
+install-prepare: FORCE
find $(BUILD_DIR)/root -type f -not -perm +0100 | xargs chmod 0644
find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
find $(BUILD_DIR)/root -type d | xargs chmod 0755
@@ -40,5 +38,5 @@ install-prepare:
chmod 0777 $(BUILD_DIR)/root/tmp
rebuild: clean prepare compile install
-clean:
+clean: FORCE
$(MAKE) clean-targets
diff --git a/openwrt/target/linux/image/aruba/Makefile b/openwrt/target/linux/image/aruba/Makefile
index 0ddde20..7ca076a 100644
--- a/openwrt/target/linux/image/aruba/Makefile
+++ b/openwrt/target/linux/image/aruba/Makefile
@@ -12,10 +12,10 @@ LOADER_MAKEOPTS= \
KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
-lzma-loader-clean:
+lzma-loader-clean: FORCE
$(MAKE) -C ../generic/lzma-loader $(LOADER_MAKEOPTS) clean
-lzma-loader-prepare:
+lzma-loader-prepare: FORCE
$(MAKE) -C ../generic/lzma-loader $(LOADER_MAKEOPTS) prepare
lzma-loader-compile: $(KDIR)/vmlinux.lzma lzma-loader-prepare
diff --git a/openwrt/target/linux/image/au1000/Makefile b/openwrt/target/linux/image/au1000/Makefile
index c7158ca..2c9b1c0 100644
--- a/openwrt/target/linux/image/au1000/Makefile
+++ b/openwrt/target/linux/image/au1000/Makefile
@@ -12,10 +12,10 @@ LOADER_MAKEOPTS= \
KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
-lzma-loader-clean:
+lzma-loader-clean: FORCE
$(MAKE) -C ../generic/lzma-loader $(LOADER_MAKEOPTS) clean
-lzma-loader-prepare:
+lzma-loader-prepare: FORCE
$(MAKE) -C ../generic/lzma-loader $(LOADER_MAKEOPTS) prepare
lzma-loader-compile: $(KDIR)/vmlinux.lzma lzma-loader-prepare
diff --git a/openwrt/target/linux/image/brcm/Makefile b/openwrt/target/linux/image/brcm/Makefile
index 0fe3cee..7e32847 100644
--- a/openwrt/target/linux/image/brcm/Makefile
+++ b/openwrt/target/linux/image/brcm/Makefile
@@ -2,10 +2,10 @@ include $(TOPDIR)/rules.mk
KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
-lzma-loader-clean:
+lzma-loader-clean: FORCE
$(MAKE) -C lzma-loader clean
-lzma-loader-prepare:
+lzma-loader-prepare: FORCE
$(MAKE) -C lzma-loader prepare
lzma-loader-compile: lzma-loader-prepare
diff --git a/openwrt/target/linux/image/jffs2.mk b/openwrt/target/linux/image/jffs2.mk
index 44d8924..c1d07a2 100644
--- a/openwrt/target/linux/image/jffs2.mk
+++ b/openwrt/target/linux/image/jffs2.mk
@@ -6,13 +6,13 @@ endif
#JFFS2OPTS += -Xlzo -msize -Xlzari
-jffs2-prepare:
+jffs2-prepare: FORCE
$(MAKE) -C jffs2 prepare
jffs2-compile: prepare-targets
$(MAKE) -C jffs2 compile
-jffs2-clean:
+jffs2-clean: FORCE
$(MAKE) -C jffs2 clean
rm -f $(KDIR)/root.jffs2*
@@ -28,11 +28,11 @@ ifeq ($(IB),)
jffs2-install: compile-targets $(BOARD)-compile
endif
-jffs2-install: $(KDIR)/root.jffs2-4MB $(KDIR)/root.jffs2-8MB
+jffs2-install: $(KDIR)/root.jffs2-4MB $(KDIR)/root.jffs2-8MB FORCE
$(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="jffs2-4MB"
$(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="jffs2-8MB"
-jffs2-install-ib: compile-targets
+jffs2-install-ib: compile-targets FORCE
mkdir -p $(IB_DIR)/staging_dir_$(ARCH)/bin
$(CP) $(STAGING_DIR)/bin/mkfs.jffs2 $(IB_DIR)/staging_dir_$(ARCH)/bin
diff --git a/openwrt/target/linux/image/jffs2/Makefile b/openwrt/target/linux/image/jffs2/Makefile
index 071bacd..0273d52 100644
--- a/openwrt/target/linux/image/jffs2/Makefile
+++ b/openwrt/target/linux/image/jffs2/Makefile
@@ -24,6 +24,6 @@ source: $(DL_DIR)/$(MTD_SOURCE)
prepare: $(MTD_DIR)/.unpacked
compile: $(MTD_DIR)/util/mkfs.jffs2 $(STAGING_DIR)/bin/mkfs.jffs2
install:
-clean:
+clean: FORCE
rm -rf $(MTD_DIR)
diff --git a/openwrt/target/linux/image/squashfs.mk b/openwrt/target/linux/image/squashfs.mk
index abe2156..184330c 100644
--- a/openwrt/target/linux/image/squashfs.mk
+++ b/openwrt/target/linux/image/squashfs.mk
@@ -4,13 +4,13 @@ else
endian := be
endif
-squashfs-prepare:
+squashfs-prepare: FORCE
$(MAKE) -C squashfs prepare
squashfs-compile: prepare-targets
$(MAKE) -C squashfs compile
-squashfs-clean:
+squashfs-clean: FORCE
$(MAKE) -C squashfs clean
rm -f $(KDIR)/root.squashfs
@@ -22,7 +22,7 @@ ifeq ($(IB),)
squashfs-install: compile-targets $(BOARD)-compile
endif
-squashfs-install: $(KDIR)/root.squashfs
+squashfs-install: $(KDIR)/root.squashfs FORCE
$(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
squashfs-install-ib: compile-targets
diff --git a/openwrt/target/linux/image/squashfs/Makefile b/openwrt/target/linux/image/squashfs/Makefile
index b5a51f8..a2b3671 100644
--- a/openwrt/target/linux/image/squashfs/Makefile
+++ b/openwrt/target/linux/image/squashfs/Makefile
@@ -23,5 +23,5 @@ source: $(DL_DIR)/$(SQUASHFSLZMA_SOURCE)
prepare: $(SQUASHFSLZMA_DIR)/.unpacked
compile: $(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs-lzma $(STAGING_DIR)/bin/mksquashfs-lzma
install:
-clean:
+clean: FORCE
rm -rf $(SQUASHFSLZMA_DIR)
diff --git a/openwrt/target/linux/image/tgz.mk b/openwrt/target/linux/image/tgz.mk
index 4ea84eb..506ab89 100644
--- a/openwrt/target/linux/image/tgz.mk
+++ b/openwrt/target/linux/image/tgz.mk
@@ -1,4 +1,4 @@
-$(KDIR)/root.tar.gz:
+$(KDIR)/root.tar.gz: FORCE
tar -zcf $@ --owner=root --group=root -C $(BUILD_DIR)/root/ .
ifeq ($(BOARD),x86)
diff --git a/openwrt/target/linux/image/x86/Makefile b/openwrt/target/linux/image/x86/Makefile
index 5820d02..8035d72 100644
--- a/openwrt/target/linux/image/x86/Makefile
+++ b/openwrt/target/linux/image/x86/Makefile
@@ -4,33 +4,28 @@ KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
ifeq ($(FS),jffs2-8MB)
-
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img: $(KDIR)/root.$(FS)
$(CP) $^ $@
install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
-
endif
ifeq ($(FS),tgz)
-
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz: $(KDIR)/root.tar.gz
$(CP) $^ $@
install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz
-
endif
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz: $(KDIR)/bzImage
$(CP) $^ $@
-
clean:
prepare:
compile:
install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
-install-ib:
+install-ib: FORCE
mkdir -p $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)
$(CP) $(KDIR)/bzImage $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)/
diff --git a/openwrt/target/linux/image/xscale/Makefile b/openwrt/target/linux/image/xscale/Makefile
index 04a89f9..cc47c25 100644
--- a/openwrt/target/linux/image/xscale/Makefile
+++ b/openwrt/target/linux/image/xscale/Makefile
@@ -2,35 +2,29 @@ include $(TOPDIR)/rules.mk
KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
-
ifeq ($(FS),jffs2-8MB)
-
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img: $(KDIR)/root.$(FS)
$(CP) $^ $@
install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
-
endif
ifeq ($(FS),tgz)
-
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz: $(KDIR)/root.tar.gz
$(CP) $^ $@
install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz
-
endif
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz: $(KDIR)/vmlinux
$(CP) $^ $@
-
clean:
prepare:
compile:
install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
-install-ib:
+install-ib: FORCE
mkdir -p $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)
$(CP) $(KDIR)/bzImage $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)/
diff --git a/openwrt/target/linux/imagebuilder/Makefile b/openwrt/target/linux/imagebuilder/Makefile
index 4afb4d4..53e8dfc 100644
--- a/openwrt/target/linux/imagebuilder/Makefile
+++ b/openwrt/target/linux/imagebuilder/Makefile
@@ -21,12 +21,12 @@ endef
include ./kernel.mk
-clean:
+clean: FORCE
@rm -rf $(LINUX_BUILD_DIR)/root*
@rm -rf $(BIN_DIR)
all:
-build:
+build: FORCE
echo
echo '### BUILDING IMAGE FROM lists/$(LIST).$(BOARD)-$(KERNEL)'
echo
diff --git a/openwrt/target/linux/kernel.mk b/openwrt/target/linux/kernel.mk
index fc33754..346fb7f 100644
--- a/openwrt/target/linux/kernel.mk
+++ b/openwrt/target/linux/kernel.mk
@@ -72,7 +72,7 @@ $(BUILD_DIR)/kernel.mk: FORCE
echo "LINUX_VERSION:=$(LINUX_VERSION)" >> $@
echo "LINUX_RELEASE:=$(LINUX_RELEASE)" >> $@
-pkg-install:
+pkg-install: FORCE
@{ [ "$(INSTALL_TARGETS)" != "" ] && $(IPKG) install $(INSTALL_TARGETS) || true; }
source: $(DL_DIR)/$(LINUX_SOURCE)
@@ -84,24 +84,21 @@ compile: prepare $(STAMP_DIR)/.linux-compile
install: compile $(LINUX_KERNEL)
-mostlyclean:
+mostlyclean: FORCE
rm -f $(STAMP_DIR)/.linux-compile
rm -f $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION)/.modules_done
rm -f $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION)/.drivers-unpacked
$(MAKE) -C $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) clean
rm -f $(LINUX_KERNEL)
-rebuild:
+rebuild: FORCE
-$(MAKE) mostlyclean
if [ -f $(LINUX_KERNEL) ]; then \
$(MAKE) clean; \
fi
$(MAKE) compile $(MAKE_TRACE)
-clean:
+clean: FORCE
rm -f $(STAMP_DIR)/.linux-compile
rm -rf $(LINUX_BUILD_DIR)
rm -f $(TARGETS)
-
-.PHONY: source prepare compile install mostlyclean rebuild clean pkg-install
-
diff --git a/openwrt/target/linux/package/Makefile b/openwrt/target/linux/package/Makefile
index ecaae0a..a8f01ff 100644
--- a/openwrt/target/linux/package/Makefile
+++ b/openwrt/target/linux/package/Makefile
@@ -26,22 +26,22 @@ install: $(patsubst %,%-install,$(package-y))
KPKG_MAKEOPTS += BUILD_DIR="$(LINUX_BUILD_DIR)"
-%-prepare:
+%-prepare: FORCE
$(MAKE) -C $(patsubst %-prepare,%,$@) \
$(KPKG_MAKEOPTS) \
prepare
-%-compile:
+%-compile: FORCE
$(MAKE) -C $(patsubst %-compile,%,$@) \
$(KPKG_MAKEOPTS) \
compile
-%-install:
+%-install: FORCE
$(MAKE) -C $(patsubst %-install,%,$@) \
$(KPKG_MAKEOPTS) \
install
-%-clean:
+%-clean: FORCE
@$(MAKE) -C $(patsubst %-clean,%,$@) \
$(KPKG_MAKEOPTS) \
clean