summaryrefslogtreecommitdiff
path: root/openwrt/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 12:54:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 12:54:17 +0000
commit6f9fbf34e662ac68a4209b59112496dbed9be1ad (patch)
treeecb2220e8646d77b0844320a3d8a6f233bee524d /openwrt/target/linux
parent8000dae1d79c68a1a48f65db9253f0cb290f77ab (diff)
downloadmtk-20170518-6f9fbf34e662ac68a4209b59112496dbed9be1ad.zip
mtk-20170518-6f9fbf34e662ac68a4209b59112496dbed9be1ad.tar.gz
mtk-20170518-6f9fbf34e662ac68a4209b59112496dbed9be1ad.tar.bz2
more V= fixes
SVN-Revision: 2234
Diffstat (limited to 'openwrt/target/linux')
-rw-r--r--openwrt/target/linux/package/Makefile2
-rw-r--r--openwrt/target/linux/package/madwifi/Makefile4
-rw-r--r--openwrt/target/linux/package/openwrt/Makefile2
3 files changed, 4 insertions, 4 deletions
diff --git a/openwrt/target/linux/package/Makefile b/openwrt/target/linux/package/Makefile
index 6b7a858..dc031fc 100644
--- a/openwrt/target/linux/package/Makefile
+++ b/openwrt/target/linux/package/Makefile
@@ -39,7 +39,7 @@ MAKEOPTS:= BOARD="$(BOARD)" \
$(MAKEOPTS) \
prepare
-%-compile: %-prepare
+%-compile:
@$(TRACE) target/linux/package/$(patsubst %-compile,%,$@)-compile
$(MAKE) -C $(patsubst %-compile,%,$@) \
$(MAKEOPTS) \
diff --git a/openwrt/target/linux/package/madwifi/Makefile b/openwrt/target/linux/package/madwifi/Makefile
index 829eed8..2f06a22 100644
--- a/openwrt/target/linux/package/madwifi/Makefile
+++ b/openwrt/target/linux/package/madwifi/Makefile
@@ -75,5 +75,5 @@ install-dev: $(STAGING_DIR)/usr/include/madwifi/net80211/ieee80211.h
uninstall-dev:
rm -rf $(STAGING_DIR)/usr/include/madwifi
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev
diff --git a/openwrt/target/linux/package/openwrt/Makefile b/openwrt/target/linux/package/openwrt/Makefile
index ef2c1ce..f55b91d 100644
--- a/openwrt/target/linux/package/openwrt/Makefile
+++ b/openwrt/target/linux/package/openwrt/Makefile
@@ -47,7 +47,7 @@ install: compile openwrt-install
openwrt-install:
$(IPKG) install $(IPKG_OPENWRT)
-compile: install-dev $(IPKG_OPENWRT)
+compile-targets: install-dev $(IPKG_OPENWRT)
install-dev:
mkdir -p $(STAGING_DIR)/usr/include
cp -fpR ./include/[a-z]* $(STAGING_DIR)/usr/include/