summaryrefslogtreecommitdiff
path: root/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-20 17:01:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-20 17:01:30 +0000
commitb6defb27cbb3f978cbf66f92f4379eeb1318b83a (patch)
treed54625559910142e0895d8a2318d003de21a286c /openwrt/target/squashfs-lzma/squashfslzmaroot.mk
parentb00ba37ec09d2d802a42d98ca6b8d32b3a0dfda2 (diff)
downloadmtk-20170518-b6defb27cbb3f978cbf66f92f4379eeb1318b83a.zip
mtk-20170518-b6defb27cbb3f978cbf66f92f4379eeb1318b83a.tar.gz
mtk-20170518-b6defb27cbb3f978cbf66f92f4379eeb1318b83a.tar.bz2
add openwrt image builder to sdk
SVN-Revision: 688
Diffstat (limited to 'openwrt/target/squashfs-lzma/squashfslzmaroot.mk')
-rw-r--r--openwrt/target/squashfs-lzma/squashfslzmaroot.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/openwrt/target/squashfs-lzma/squashfslzmaroot.mk b/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
index ca493d7..11b2b76 100644
--- a/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
+++ b/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
@@ -16,10 +16,13 @@ $(SQUASHFSLZMA_DIR)/.unpacked: $(DL_DIR)/$(SQUASHFSLZMA_SOURCE)
patch -d $(SQUASHFSLZMA_DIR) -p1 < squashfs2.0-tools-lzma.patch
touch $(SQUASHFSLZMA_DIR)/.unpacked
-$(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs: $(SQUASHFSLZMA_DIR)/.unpacked
+$(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs-lzma: $(SQUASHFSLZMA_DIR)/.unpacked
$(MAKE) -C $(SQUASHFSLZMA_DIR)/squashfs-tools mksquashfs-lzma LZMAPATH=$(BUILD_DIR)/lzma
-squashfslzma: $(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs
+$(STAGING_DIR)/bin/mksquashfs-lzma: $(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs-lzma
+ cp $< $@
+
+squashfslzma: $(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs-lzma $(STAGING_DIR)/bin/mksquashfs-lzma
squashfslzma-source: $(DL_DIR)/$(SQUASHFSLZMA_SOURCE)