summaryrefslogtreecommitdiff
path: root/openwrt/target/squashfs-lzma
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2005-03-06 03:34:52 +0000
committerMike Baker <mbm@openwrt.org>2005-03-06 03:34:52 +0000
commit6b93231c4f64a61103dfc16acebedd18b4c25171 (patch)
treeaad933069e7dedf29eb70dbfd81e9ca95d9b578f /openwrt/target/squashfs-lzma
parent14e0fec336fca0766605968fe9dd7eef2448736f (diff)
downloadmtk-20170518-6b93231c4f64a61103dfc16acebedd18b4c25171.zip
mtk-20170518-6b93231c4f64a61103dfc16acebedd18b4c25171.tar.gz
mtk-20170518-6b93231c4f64a61103dfc16acebedd18b4c25171.tar.bz2
nbd's makefile/menuconfig rewrite
SVN-Revision: 307
Diffstat (limited to 'openwrt/target/squashfs-lzma')
-rw-r--r--openwrt/target/squashfs-lzma/Config.in5
-rw-r--r--openwrt/target/squashfs-lzma/Makefile16
-rw-r--r--openwrt/target/squashfs-lzma/squashfslzmaroot.mk20
3 files changed, 16 insertions, 25 deletions
diff --git a/openwrt/target/squashfs-lzma/Config.in b/openwrt/target/squashfs-lzma/Config.in
deleted file mode 100644
index cc46d10..0000000
--- a/openwrt/target/squashfs-lzma/Config.in
+++ /dev/null
@@ -1,5 +0,0 @@
-config BR2_TARGET_ROOTFS_SQUASHFS_LZMA
- bool "squashfs-lzma"
- help
- Build a squashfs-lzma root filesystem
-
diff --git a/openwrt/target/squashfs-lzma/Makefile b/openwrt/target/squashfs-lzma/Makefile
new file mode 100644
index 0000000..6c70995
--- /dev/null
+++ b/openwrt/target/squashfs-lzma/Makefile
@@ -0,0 +1,16 @@
+include $(TOPDIR)/rules.mk
+include ./squashfslzmaroot.mk
+
+TARGETS:=$(BIN_DIR)/openwrt-generic-squashfs.trx
+
+prepare: $(SQUASHFSLZMA_DIR)/.unpacked
+compile: squashfslzma
+install: $(TARGETS)
+clean: squashfslzmaroot-dirclean
+
+$(BIN_DIR)/openwrt-generic-squashfs.trx:
+ @mkdir -p $(TARGET_DIR)/jffs
+ $(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs-lzma $(TARGET_DIR) $(IMAGE).squashfslzma -noappend -root-owned -le
+ PATH=$(TARGET_PATH) trx -o $@ \
+ $(LINUX_KERNEL) $(IMAGE).squashfslzma
+
diff --git a/openwrt/target/squashfs-lzma/squashfslzmaroot.mk b/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
index 1aa80e0..ee7ede8 100644
--- a/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
+++ b/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
@@ -36,27 +36,7 @@ squashfslzma-dirclean:
#
#############################################################
-squashfslzmaroot: squashfslzma
- @rm -rf $(TARGET_DIR)/usr/man
- @rm -rf $(TARGET_DIR)/usr/info
- $(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs-lzma \
- $(TARGET_DIR) $(IMAGE).squashfslzma -noappend -root-owned -le
-
squashfslzmaroot-source: squashfslzma-source
-squashfslzmaroot-clean:
- -$(MAKE) -C $(SQUASHFSLZMA_DIR) clean
-
squashfslzmaroot-dirclean:
rm -rf $(SQUASHFSLZMA_DIR)
-
-ifeq ($(strip $(BR2_TARGET_ROOTFS_SQUASHFS_LZMA)),y)
-TARGETS+=squashfslzmaroot openwrt-image
-ROOTFS=squashfslzma
-
-openwrt-image: openwrt
- @make openwrt-code.bin TAG=W54G \
- EXTRAVERSION=$(EXTRAVERSION)-SQUASHFSLZMA
- @make openwrt-code.bin TAG=W54S \
- EXTRAVERSION=$(EXTRAVERSION)-SQUASHFSLZMA
-endif