summaryrefslogtreecommitdiff
path: root/openwrt/target
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2005-02-12 06:12:34 +0000
committerMike Baker <mbm@openwrt.org>2005-02-12 06:12:34 +0000
commit12b57f6a9991070d82409012d0b621c94fa4a7b0 (patch)
treecfb62e642bf9597148bdf44222dbdd3d0bb2cb6c /openwrt/target
parent8ce3ed00616c8997c98799a673ffcb8d2cdc1652 (diff)
downloadmtk-20170518-12b57f6a9991070d82409012d0b621c94fa4a7b0.zip
mtk-20170518-12b57f6a9991070d82409012d0b621c94fa4a7b0.tar.gz
mtk-20170518-12b57f6a9991070d82409012d0b621c94fa4a7b0.tar.bz2
cleanup the whole addpattern / trx nonsense
SVN-Revision: 243
Diffstat (limited to 'openwrt/target')
-rw-r--r--openwrt/target/Config.in14
-rw-r--r--openwrt/target/jffs2/Config.in2
-rw-r--r--openwrt/target/jffs2/Makefile.in1
-rw-r--r--openwrt/target/jffs2/jffs2root.mk13
-rw-r--r--openwrt/target/squashfs/Config.in2
-rw-r--r--openwrt/target/squashfs/Makefile.in3
-rw-r--r--openwrt/target/squashfs/squashfsroot.mk11
7 files changed, 10 insertions, 36 deletions
diff --git a/openwrt/target/Config.in b/openwrt/target/Config.in
index c2576fd..791741a 100644
--- a/openwrt/target/Config.in
+++ b/openwrt/target/Config.in
@@ -1,9 +1,5 @@
-#
-
-menu "Target Filesystem"
-
-source "target/jffs2/Config.in"
-source "target/squashfs/Config.in"
-
-endmenu
-
+choice
+ prompt "Target Root Filesystem"
+ source "target/jffs2/Config.in"
+ source "target/squashfs/Config.in"
+endchoice
diff --git a/openwrt/target/jffs2/Config.in b/openwrt/target/jffs2/Config.in
index 0d79dd1..ae14ad9 100644
--- a/openwrt/target/jffs2/Config.in
+++ b/openwrt/target/jffs2/Config.in
@@ -1,5 +1,5 @@
config BR2_TARGET_ROOTFS_JFFS2
- bool "jffs2 root filesystem for the target device"
+ bool "jffs2"
default n
help
Build a jffs2 root filesystem
diff --git a/openwrt/target/jffs2/Makefile.in b/openwrt/target/jffs2/Makefile.in
index 1da4903..ab8c2a8 100644
--- a/openwrt/target/jffs2/Makefile.in
+++ b/openwrt/target/jffs2/Makefile.in
@@ -1,3 +1,4 @@
ifeq ($(strip $(BR2_TARGET_ROOTFS_JFFS2)),y)
TARGETS+=jffs2root openwrt-image-jffs2
+ROOTFS=jffs2
endif
diff --git a/openwrt/target/jffs2/jffs2root.mk b/openwrt/target/jffs2/jffs2root.mk
index 7d30f4c..75f55ae 100644
--- a/openwrt/target/jffs2/jffs2root.mk
+++ b/openwrt/target/jffs2/jffs2root.mk
@@ -44,16 +44,3 @@ jffs2root-clean:
jffs2root-dirclean:
rm -rf $(MTD_DIR)
-
-openwrt-linux.trx.jffs2:
- $(BUILD_DIR)/trx -o openwrt-linux.trx.jffs2 $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).jffs2
-
-openwrt-gs-code.bin.jffs2: openwrt-linux.trx.jffs2
- $(BUILD_DIR)/addpattern -2 -i openwrt-linux.trx.jffs2 -o openwrt-gs-code.bin.jffs2 -g
-
-openwrt-g-code.bin.jffs2: openwrt-gs-code.bin.jffs2
- sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin.jffs2 > openwrt-g-code.bin.jffs2
-
-openwrt-image-jffs2: openwrt-g-code.bin.jffs2
-
-
diff --git a/openwrt/target/squashfs/Config.in b/openwrt/target/squashfs/Config.in
index a4cb4d8..3ef5d22 100644
--- a/openwrt/target/squashfs/Config.in
+++ b/openwrt/target/squashfs/Config.in
@@ -1,5 +1,5 @@
config BR2_TARGET_ROOTFS_SQUASHFS
- bool "squashfs (ro) root filesystem for the target device"
+ bool "squashfs"
default n
help
Build a squashfs root filesystem
diff --git a/openwrt/target/squashfs/Makefile.in b/openwrt/target/squashfs/Makefile.in
index e3e1006..14b7f74 100644
--- a/openwrt/target/squashfs/Makefile.in
+++ b/openwrt/target/squashfs/Makefile.in
@@ -1,3 +1,4 @@
ifeq ($(strip $(BR2_TARGET_ROOTFS_SQUASHFS)),y)
-TARGETS+=squashfsroot openwrt-image-squashfs
+TARGETS+=squashfsroot
+ROOTFS=squashfs
endif
diff --git a/openwrt/target/squashfs/squashfsroot.mk b/openwrt/target/squashfs/squashfsroot.mk
index fce7164..4dd6800 100644
--- a/openwrt/target/squashfs/squashfsroot.mk
+++ b/openwrt/target/squashfs/squashfsroot.mk
@@ -47,14 +47,3 @@ squashfsroot-clean:
squashfsroot-dirclean:
rm -rf $(SQUASHFS_DIR)
-
-openwrt-linux.trx.squashfs:
- $(BUILD_DIR)/trx -o openwrt-linux.trx.squashfs $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).squashfs
-
-openwrt-gs-code.bin.squashfs: openwrt-linux.trx.squashfs
- $(BUILD_DIR)/addpattern -2 -i openwrt-linux.trx.squashfs -o openwrt-gs-code.bin.squashfs -g
-
-openwrt-g-code.bin.squashfs: openwrt-gs-code.bin.squashfs
- sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin.squashfs > openwrt-g-code.bin.squashfs
-
-openwrt-image-squashfs: openwrt-g-code.bin.squashfs