summaryrefslogtreecommitdiff
path: root/openwrt/target
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2005-02-26 02:32:16 +0000
committerMike Baker <mbm@openwrt.org>2005-02-26 02:32:16 +0000
commit6e1c4d0da3ba45b4a1c2bfba79b07216dcb252b9 (patch)
tree974dde8f6003d98e97764410cbbbe1ccfe6b5138 /openwrt/target
parent5ead46cce658c94abc27e8ae7411f28b2804e5f9 (diff)
downloadmtk-20170518-6e1c4d0da3ba45b4a1c2bfba79b07216dcb252b9.zip
mtk-20170518-6e1c4d0da3ba45b4a1c2bfba79b07216dcb252b9.tar.gz
mtk-20170518-6e1c4d0da3ba45b4a1c2bfba79b07216dcb252b9.tar.bz2
bugfix
SVN-Revision: 294
Diffstat (limited to 'openwrt/target')
-rwxr-xr-xopenwrt/target/default/target_skeleton/etc/preinit6
-rw-r--r--openwrt/target/squashfs-lzma/squashfslzmaroot.mk1
-rw-r--r--openwrt/target/squashfs/squashfsroot.mk1
3 files changed, 3 insertions, 5 deletions
diff --git a/openwrt/target/default/target_skeleton/etc/preinit b/openwrt/target/default/target_skeleton/etc/preinit
index d2036f4..28fe805 100755
--- a/openwrt/target/default/target_skeleton/etc/preinit
+++ b/openwrt/target/default/target_skeleton/etc/preinit
@@ -11,10 +11,10 @@ else
mtd unlock mtd4
mount -t jffs2 /dev/mtdblock/4 /jffs
pivot_root /jffs /jffs/rom
- mount none /dev -t devfs
- mount none /proc -t proc
- umount rom/proc
}
+ mount none /dev -t devfs
+ mount none /proc -t proc
+ umount rom/proc
fi
mount none /tmp -t ramfs
exec /sbin/init
diff --git a/openwrt/target/squashfs-lzma/squashfslzmaroot.mk b/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
index 4059896..722c205 100644
--- a/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
+++ b/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
@@ -39,7 +39,6 @@ squashfslzma-dirclean:
squashfslzmaroot: squashfslzma
@rm -rf $(TARGET_DIR)/usr/man
@rm -rf $(TARGET_DIR)/usr/info
- @mkdir -p $(TARGET_DIR)/jffs
$(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs-lzma $(TARGET_DIR) $(IMAGE).squashfslzma -noappend -root-owned -le
squashfslzmaroot-source: squashfslzma-source
diff --git a/openwrt/target/squashfs/squashfsroot.mk b/openwrt/target/squashfs/squashfsroot.mk
index 62b645a..d3a104a 100644
--- a/openwrt/target/squashfs/squashfsroot.mk
+++ b/openwrt/target/squashfs/squashfsroot.mk
@@ -38,7 +38,6 @@ squashfs-dirclean:
squashfsroot: squashfs
@rm -rf $(TARGET_DIR)/usr/man
@rm -rf $(TARGET_DIR)/usr/info
- @mkdir -p $(TARGET_DIR)/jffs
$(SQUASHFS_DIR)/squashfs-tools/mksquashfs $(TARGET_DIR) $(IMAGE).squashfs -noappend -root-owned -le
squashfsroot-source: squashfs-source