summaryrefslogtreecommitdiff
path: root/openwrt/target
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-12-11 21:13:08 +0000
committerNicolas Thill <nico@openwrt.org>2005-12-11 21:13:08 +0000
commitf59b137053d466103342570bedc7053f090b94a7 (patch)
tree82065abd83f28ea3ec9e0f15caa07f09170d80ea /openwrt/target
parentd38cf9ad6cf3f5d5c3881f151b125d6a2a93fe20 (diff)
downloadmtk-20170518-f59b137053d466103342570bedc7053f090b94a7.zip
mtk-20170518-f59b137053d466103342570bedc7053f090b94a7.tar.gz
mtk-20170518-f59b137053d466103342570bedc7053f090b94a7.tar.bz2
fix 2.4 build error introduced by changeset:2606
SVN-Revision: 2613
Diffstat (limited to 'openwrt/target')
-rw-r--r--openwrt/target/linux/package/spca5xx/Makefile1
-rw-r--r--openwrt/target/linux/package/spca5xx/patches/01-kmod-build.patch2
2 files changed, 2 insertions, 1 deletions
diff --git a/openwrt/target/linux/package/spca5xx/Makefile b/openwrt/target/linux/package/spca5xx/Makefile
index 95a48a9..d61a04a 100644
--- a/openwrt/target/linux/package/spca5xx/Makefile
+++ b/openwrt/target/linux/package/spca5xx/Makefile
@@ -18,6 +18,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
ifeq ($(KERNEL_DIR),)
KERNEL_DIR:=$(LINUX_DIR)
endif
+KERNEL_VERSION=$(shell echo "$(LINUX_VERSION)" | cut -d. -f1,2)
include $(TOPDIR)/package/rules.mk
diff --git a/openwrt/target/linux/package/spca5xx/patches/01-kmod-build.patch b/openwrt/target/linux/package/spca5xx/patches/01-kmod-build.patch
index f69caf8..eb7dccd 100644
--- a/openwrt/target/linux/package/spca5xx/patches/01-kmod-build.patch
+++ b/openwrt/target/linux/package/spca5xx/patches/01-kmod-build.patch
@@ -26,7 +26,7 @@ diff -ruN spca5xx-20051105-old/Makefile spca5xx-20051105-new/Makefile
-# This makefile will build the spca50x driver module external to the kernel
-# source tree. It makes it easier to swap kernels.
-
-+CFLAGS += $(DEFINES)
++EXTRA_CFLAGS += $(DEFINES)
-KERNEL_VERSION = `uname -r`
+spca5xx-objs := drivers/usb/spca5xx.o drivers/usb/spcadecoder.o