summaryrefslogtreecommitdiff
path: root/openwrt/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-25 10:16:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-25 10:16:56 +0000
commit302930ee2c0d1a4f5a6a1dd99ad51e73bda04477 (patch)
tree3c78aaad09a3c014afd6378784830ff6ad9bff54 /openwrt/target
parent06ef24042b46e4463eaeaafa74193b9574922ede (diff)
downloadmtk-20170518-302930ee2c0d1a4f5a6a1dd99ad51e73bda04477.zip
mtk-20170518-302930ee2c0d1a4f5a6a1dd99ad51e73bda04477.tar.gz
mtk-20170518-302930ee2c0d1a4f5a6a1dd99ad51e73bda04477.tar.bz2
fix base-files-arch package
SVN-Revision: 1558
Diffstat (limited to 'openwrt/target')
-rw-r--r--openwrt/target/linux/package/openwrt/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/openwrt/target/linux/package/openwrt/Makefile b/openwrt/target/linux/package/openwrt/Makefile
index 75053b1..2f90631 100644
--- a/openwrt/target/linux/package/openwrt/Makefile
+++ b/openwrt/target/linux/package/openwrt/Makefile
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME := base-files-arch
PKG_RELEASE := 1
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)-$(BOARD)
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
include $(TOPDIR)/package/rules.mk
@@ -35,13 +35,15 @@ $(IDIR_OPENWRT):
$(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_OPENWRT) ipkg/base-files-arch.control $(PKG_RELEASE) $(ARCH)
$(SED) s,base-files-arch,base-files-$(BOARD),g $(IDIR_OPENWRT)/CONTROL/control
-$(IPKG_OPENWRT):
+$(IPKG_OPENWRT): $(IDIR_OPENWRT)
mkdir -p $(IDIR_OPENWRT)/etc
cp files/network.overrides.$(BOARD) $(IDIR_OPENWRT)/etc/network.overrides
$(RSTRIP) $(IDIR_OPENWRT)
$(IPKG_BUILD) $(IDIR_OPENWRT) $(PACKAGE_DIR)
-compile: install-dev
+install: $(IPKG_OPENWRT)
+ $(IPKG) install $(IPKG_OPENWRT)
+compile: install-dev $(IPKG_OPENWRT)
install-dev:
mkdir -p $(STAGING_DIR)/usr/include
cp -a ./include/* $(STAGING_DIR)/usr/include/