summaryrefslogtreecommitdiff
path: root/openwrt/target
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-04-01 14:51:48 +0000
committerNicolas Thill <nico@openwrt.org>2006-04-01 14:51:48 +0000
commit4c04f649fe8fc4b596a8e3418d3644aa5878ab47 (patch)
tree9f6a18c032b20defada8482c0e2b9acec93bdeca /openwrt/target
parent43ce8fb570e128ecc8055d3239c1a169f18d573f (diff)
downloadmtk-20170518-4c04f649fe8fc4b596a8e3418d3644aa5878ab47.zip
mtk-20170518-4c04f649fe8fc4b596a8e3418d3644aa5878ab47.tar.gz
mtk-20170518-4c04f649fe8fc4b596a8e3418d3644aa5878ab47.tar.bz2
load of ide modules at boot (closes: #439)
SVN-Revision: 3565
Diffstat (limited to 'openwrt/target')
-rw-r--r--openwrt/target/linux/Config.in6
-rw-r--r--openwrt/target/linux/generic-2.4/modules.mk2
2 files changed, 7 insertions, 1 deletions
diff --git a/openwrt/target/linux/Config.in b/openwrt/target/linux/Config.in
index e81b099..7a41675 100644
--- a/openwrt/target/linux/Config.in
+++ b/openwrt/target/linux/Config.in
@@ -287,6 +287,12 @@ config BR2_PACKAGE_KMOD_IDE
help
Kernel modules for IDE support
useful for usb mass storage devices (e.g. on WL-HDD)
+
+ Includes:
+ - ide-core
+ - ide-detect
+ - ide-disk
+ - pdc202xx_old
config BR2_PACKAGE_KMOD_LOOP
prompt "kmod-loop......................... Loop mount support"
diff --git a/openwrt/target/linux/generic-2.4/modules.mk b/openwrt/target/linux/generic-2.4/modules.mk
index 705b702..f35e9ba 100644
--- a/openwrt/target/linux/generic-2.4/modules.mk
+++ b/openwrt/target/linux/generic-2.4/modules.mk
@@ -110,7 +110,7 @@ $(eval $(call KMOD_template,IP6TABLES,ip6tables,\
$(eval $(call KMOD_template,IDE,ide,\
$(MODULES_DIR)/kernel/drivers/ide/*.o \
$(MODULES_DIR)/kernel/drivers/ide/*/*.o \
-,CONFIG_IDE))
+,CONFIG_IDE,,20,pdc202xx_old ide-core ide-detect ide-disk))
$(eval $(call KMOD_template,LOOP,loop,\
$(MODULES_DIR)/kernel/drivers/block/loop.o \