summaryrefslogtreecommitdiff
path: root/openwrt/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-25 10:26:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-25 10:26:39 +0000
commit9820068f2115547c34c0bbc454e5024c907b16a9 (patch)
treebb0af0f6c91c60eb2e4907abcf544e2db67aca0e /openwrt/target
parent302930ee2c0d1a4f5a6a1dd99ad51e73bda04477 (diff)
downloadmtk-20170518-9820068f2115547c34c0bbc454e5024c907b16a9.zip
mtk-20170518-9820068f2115547c34c0bbc454e5024c907b16a9.tar.gz
mtk-20170518-9820068f2115547c34c0bbc454e5024c907b16a9.tar.bz2
fix package install order
SVN-Revision: 1559
Diffstat (limited to 'openwrt/target')
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index 5b6c71d..701423c 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -239,7 +239,6 @@ compile: $(LINUX_DIR)/.modules_done $(TARGETS)
install: compile $(TARGET_MODULES_DIR) $(KERNEL_IPKG)
rm -rf $(LINUX_BUILD_DIR)/root*
echo -e 'dest root /\noption offline_root $(LINUX_BUILD_DIR)/root' > $(LINUX_BUILD_DIR)/ipkg.conf
- [ "$(INSTALL_TARGETS)" != "" ] && $(IPKG_KERNEL) install $(INSTALL_TARGETS) || true
$(MAKE) -C $(TOPDIR)/package \
TARGET_DIR="$(LINUX_TARGET_DIR)" \
IPKG_CONF="$(LINUX_BUILD_DIR)" \
@@ -248,6 +247,7 @@ install: compile $(TARGET_MODULES_DIR) $(KERNEL_IPKG)
$(MAKE) -C $(TOPDIR)/target/linux/package \
$(KPKG_MAKEOPTS) \
install
+ [ "$(INSTALL_TARGETS)" != "" ] && $(IPKG_KERNEL) install $(INSTALL_TARGETS) || true
mostlyclean:
rm -f $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION)/.modules_done