summaryrefslogtreecommitdiff
path: root/openwrt/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-21 17:41:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-21 17:41:49 +0000
commitc534539555312db0e3aecae7df90b08819c518d9 (patch)
tree3021a82480e5bb541d04f5a77624a023ce5273cc /openwrt/target
parent85cd39878dfe92c1b403b8833ed6b5b9d2409390 (diff)
downloadmtk-20170518-c534539555312db0e3aecae7df90b08819c518d9.zip
mtk-20170518-c534539555312db0e3aecae7df90b08819c518d9.tar.gz
mtk-20170518-c534539555312db0e3aecae7df90b08819c518d9.tar.bz2
fix nvram compile
SVN-Revision: 1523
Diffstat (limited to 'openwrt/target')
-rw-r--r--openwrt/target/linux/package/nvram/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/openwrt/target/linux/package/nvram/Makefile b/openwrt/target/linux/package/nvram/Makefile
index da67ffa..3f7626a 100644
--- a/openwrt/target/linux/package/nvram/Makefile
+++ b/openwrt/target/linux/package/nvram/Makefile
@@ -10,7 +10,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
include $(TOPDIR)/package/rules.mk
BR2_PACKAGE_NVRAM:=y # does not depend on menuconfig
-$(eval $(call PKG_template,NVRAM,nvram,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,NVRAM,nvram,$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.prepared:
mkdir -p $(PKG_BUILD_DIR)
@@ -31,3 +31,9 @@ $(IPKG_NVRAM):
$(RSTRIP) $(IDIR_NVRAM)
$(IPKG_BUILD) $(IDIR_NVRAM) $(PACKAGE_DIR)
+
+compile: install-dev
+install-dev:
+ cp $(PKG_BUILD_DIR)/*.so $(STAGING_DIR)/usr/lib
+
+