summaryrefslogtreecommitdiff
path: root/openwrt/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-08 09:08:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-08 09:08:38 +0000
commitb7d92815a6aaefcf2aa6240346445530473e9c1e (patch)
tree66a9a28ea0c69b059939becc0f335bc8ec1d5437 /openwrt/target
parent322b84237cee9e9adb88d32af8f20f384066866e (diff)
downloadmtk-20170518-b7d92815a6aaefcf2aa6240346445530473e9c1e.zip
mtk-20170518-b7d92815a6aaefcf2aa6240346445530473e9c1e.tar.gz
mtk-20170518-b7d92815a6aaefcf2aa6240346445530473e9c1e.tar.bz2
add some fixes for parallel build (does not work with -j4 yet, but it gets most packages compiled now)
SVN-Revision: 577
Diffstat (limited to 'openwrt/target')
-rw-r--r--openwrt/target/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/openwrt/target/Makefile b/openwrt/target/Makefile
index 6a1bd95..437609a 100644
--- a/openwrt/target/Makefile
+++ b/openwrt/target/Makefile
@@ -73,6 +73,7 @@ $(BIN_DIR):
mkdir -p $(BIN_DIR)
$(INSTALL_TARGET_DIRS): lzma-loader-compile
+$(IMAGE_TARGETS): $(patsubst %,%-install,$(TARGET_DIRS))
compile: $(patsubst %,%-compile,$(TARGET_DIRS))
install: utils-install lzma-install $(LINUX_IMAGE) $(patsubst %,%-install,$(TARGET_DIRS)) $(IMAGE_TARGETS)
clean: $(patsubst %,%-clean,$(TARGET_DIRS)) image_clean