summaryrefslogtreecommitdiff
path: root/openwrt/target
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-11-15 08:23:42 +0000
committerNicolas Thill <nico@openwrt.org>2005-11-15 08:23:42 +0000
commit5de370fbe29d3d20ca8a79b5b61045d3c5cdc375 (patch)
tree0ee77f7a883d9ededfefc2ee872ac4a20eba5e7c /openwrt/target
parent15e214dd89dea138ee1c976aa1bbef1f72217c7e (diff)
downloadmtk-20170518-5de370fbe29d3d20ca8a79b5b61045d3c5cdc375.zip
mtk-20170518-5de370fbe29d3d20ca8a79b5b61045d3c5cdc375.tar.gz
mtk-20170518-5de370fbe29d3d20ca8a79b5b61045d3c5cdc375.tar.bz2
fix kernel package and kernel modules dependency on it
SVN-Revision: 2492
Diffstat (limited to 'openwrt/target')
-rw-r--r--openwrt/target/linux/control/kernel.control1
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile3
-rw-r--r--openwrt/target/linux/linux-2.6/Makefile3
-rw-r--r--openwrt/target/linux/rules.mk6
4 files changed, 4 insertions, 9 deletions
diff --git a/openwrt/target/linux/control/kernel.control b/openwrt/target/linux/control/kernel.control
index 32e6fdc..5432d21 100644
--- a/openwrt/target/linux/control/kernel.control
+++ b/openwrt/target/linux/control/kernel.control
@@ -1,3 +1,4 @@
+Package: kernel
Priority: optional
Section: sys
Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index d487446..3982896 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -426,8 +426,7 @@ $(TARGET_MODULES_DIR):
$(KERNEL_IPKG):
rm -rf $(KERNEL_IDIR)
mkdir -p $(KERNEL_IDIR)/etc
- $(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(PKG_RELEASE) $(ARCH)
- echo 'Package: kernel-$(LINUX_VERSION)-$(BOARD)' >> $(KERNEL_IDIR)/CONTROL/control
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE) $(ARCH)
if [ -f ./config/$(BOARD).modules ]; then \
cp ./config/$(BOARD).modules $(KERNEL_IDIR)/etc/modules; \
fi
diff --git a/openwrt/target/linux/linux-2.6/Makefile b/openwrt/target/linux/linux-2.6/Makefile
index ce49930..212a4a7 100644
--- a/openwrt/target/linux/linux-2.6/Makefile
+++ b/openwrt/target/linux/linux-2.6/Makefile
@@ -444,8 +444,7 @@ $(TARGET_MODULES_DIR):
$(KERNEL_IPKG):
rm -rf $(KERNEL_IDIR)
mkdir -p $(KERNEL_IDIR)/etc
- $(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(PKG_RELEASE) $(ARCH)
- echo 'Package: kernel-$(LINUX_VERSION)-$(BOARD)' >> $(KERNEL_IDIR)/CONTROL/control
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE) $(ARCH)
if [ -f ./config/$(BOARD).modules ]; then \
cp ./config/$(BOARD).modules $(KERNEL_IDIR)/etc/modules; \
fi
diff --git a/openwrt/target/linux/rules.mk b/openwrt/target/linux/rules.mk
index be151ea..8871fa4 100644
--- a/openwrt/target/linux/rules.mk
+++ b/openwrt/target/linux/rules.mk
@@ -17,11 +17,7 @@ else
KDEPEND_$(1):=$($(4))
endif
-ifeq ($$(strip $(5)),)
-IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE))
-else
-IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE)), $(5)
-endif
+IDEPEND_$(1):=kernel ($(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)) $(foreach pkg,$(5),", $(pkg)")
PKG_$(1) := $(PACKAGE_DIR)/kmod-$(2)_$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)_$(ARCH).ipk
I_$(1) := $(PKG_BUILD_DIR)/ipkg/$(2)