summaryrefslogtreecommitdiff
path: root/openwrt/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-21 02:16:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-21 02:16:37 +0000
commit4e24e35fa9083cfe57d7b1fe7b51c5f2f6515f18 (patch)
tree379281bd9ec7a759ee793459a5b441d36ccbb5be /openwrt/toolchain/Makefile
parent99bc02a12be0b7725b2917e2b25c25e446f67717 (diff)
downloadmtk-20170518-4e24e35fa9083cfe57d7b1fe7b51c5f2f6515f18.zip
mtk-20170518-4e24e35fa9083cfe57d7b1fe7b51c5f2f6515f18.tar.gz
mtk-20170518-4e24e35fa9083cfe57d7b1fe7b51c5f2f6515f18.tar.bz2
build system cleanup. move shared include files into $(TOPDIR)/include, move lzma, mkfs.* into toolchain/
SVN-Revision: 4032
Diffstat (limited to 'openwrt/toolchain/Makefile')
-rw-r--r--openwrt/toolchain/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/openwrt/toolchain/Makefile b/openwrt/toolchain/Makefile
index fac0468..f9fb3a5 100644
--- a/openwrt/toolchain/Makefile
+++ b/openwrt/toolchain/Makefile
@@ -1,6 +1,6 @@
# Main makefile for the toolchain
include $(TOPDIR)/rules.mk
-TARGETS-y:=sed kernel-headers utils binutils gcc uClibc ipkg-utils libnotimpl
+TARGETS-y:=sed kernel-headers utils binutils gcc uClibc ipkg-utils libnotimpl squashfs jffs2 lzma
TARGETS-$(CONFIG_GDB) += gdb
TARGETS_DOWNLOAD:=$(patsubst %,%-source,$(TARGETS-y))
@@ -17,6 +17,7 @@ binutils-prepare: uClibc-prepare
gcc-prepare: binutils-install
uClibc-compile: gcc-prepare
gcc-compile: uClibc-install
+squashfs-compile: lzma-compile
TOOLCHAIN_STAMP_DIR:=$(STAGING_DIR)/stampfiles