summaryrefslogtreecommitdiff
path: root/openwrt/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-21 06:19:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-21 06:19:43 +0000
commite248cf0f00917eb91b93a3d16c36a4aa544f575c (patch)
tree546646a962e82e608e7feb1e7e1b91fdceb88a6a /openwrt/toolchain/Makefile
parent1f20179ce5c9774f17d843070cd39da3f2e62268 (diff)
downloadmtk-20170518-e248cf0f00917eb91b93a3d16c36a4aa544f575c.zip
mtk-20170518-e248cf0f00917eb91b93a3d16c36a4aa544f575c.tar.gz
mtk-20170518-e248cf0f00917eb91b93a3d16c36a4aa544f575c.tar.bz2
massive cleanup of toolchain/
SVN-Revision: 4038
Diffstat (limited to 'openwrt/toolchain/Makefile')
-rw-r--r--openwrt/toolchain/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/openwrt/toolchain/Makefile b/openwrt/toolchain/Makefile
index f9fb3a5..6481ed0 100644
--- a/openwrt/toolchain/Makefile
+++ b/openwrt/toolchain/Makefile
@@ -1,6 +1,6 @@
# Main makefile for the toolchain
include $(TOPDIR)/rules.mk
-TARGETS-y:=sed kernel-headers utils binutils gcc uClibc ipkg-utils libnotimpl squashfs jffs2 lzma
+TARGETS-y:=sed kernel-headers sstrip binutils gcc uClibc ipkg-utils libnotimpl squashfs jffs2 lzma
TARGETS-$(CONFIG_GDB) += gdb
TARGETS_DOWNLOAD:=$(patsubst %,%-source,$(TARGETS-y))
@@ -12,12 +12,13 @@ download: $(TARGETS_DOWNLOAD)
install: $(TARGETS_INSTALL)
clean: $(TARGETS_CLEAN)
-uClibc-prepare: kernel-headers-prepare sed-install utils-install
+kernel-headers-prepare: sed-install
+uClibc-prepare: kernel-headers-prepare sstrip-install
binutils-prepare: uClibc-prepare
gcc-prepare: binutils-install
-uClibc-compile: gcc-prepare
-gcc-compile: uClibc-install
-squashfs-compile: lzma-compile
+uClibc-compile: gcc-compile
+gcc-install: uClibc-install
+squashfs-compile: lzma-install
TOOLCHAIN_STAMP_DIR:=$(STAGING_DIR)/stampfiles