summaryrefslogtreecommitdiff
path: root/openwrt/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-17 22:52:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-17 22:52:59 +0000
commit8cf55878a814d1a6708817adce2819373ae3883e (patch)
tree56a8d56d6b30807c4241db07dd6ac9263eedd4e6 /openwrt/toolchain/Makefile
parenta9a51421ce9d685576836537b2776be6c788785f (diff)
downloadmtk-20170518-8cf55878a814d1a6708817adce2819373ae3883e.zip
mtk-20170518-8cf55878a814d1a6708817adce2819373ae3883e.tar.gz
mtk-20170518-8cf55878a814d1a6708817adce2819373ae3883e.tar.bz2
move target/default/target_skeleton into package/base-files, put all the default files in ipkg packages, cleanup some junk in toolchain/, toolchain/ no longer changes build_mipsel/root
SVN-Revision: 1494
Diffstat (limited to 'openwrt/toolchain/Makefile')
-rw-r--r--openwrt/toolchain/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/openwrt/toolchain/Makefile b/openwrt/toolchain/Makefile
index c573deb..2b1358b 100644
--- a/openwrt/toolchain/Makefile
+++ b/openwrt/toolchain/Makefile
@@ -15,8 +15,10 @@ gcc-prepare: binutils-install
uClibc-compile: gcc-prepare
gcc-compile: uClibc-install
-$(STAMP_DIR):
- mkdir -p $(STAMP_DIR)
+TOOLCHAIN_STAMP_DIR:=$(STAGING_DIR)/stampfiles
+
+$(TOOLCHAIN_STAMP_DIR):
+ mkdir -p $(TOOLCHAIN_STAMP_DIR)
$(STAGING_DIR):
@mkdir -p $(STAGING_DIR)/lib
@@ -27,19 +29,19 @@ $(STAGING_DIR):
$(TOOL_BUILD_DIR):
@mkdir -p $(TOOL_BUILD_DIR)
-%-prepare: $(STAMP_DIR) $(STAGING_DIR) $(TOOL_BUILD_DIR)
- @[ -f $(STAMP_DIR)/.toolchain_$@ ] || $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
- @touch $(STAMP_DIR)/.toolchain_$@
+%-prepare: $(TOOLCHAIN_STAMP_DIR) $(STAGING_DIR) $(TOOL_BUILD_DIR)
+ @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
+ @touch $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@
%-compile: %-prepare
- @[ -f $(STAMP_DIR)/.toolchain_$@ ] || $(MAKE) -C $(patsubst %-compile,%,$@) compile
- @touch $(STAMP_DIR)/.toolchain_$@
+ @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || $(MAKE) -C $(patsubst %-compile,%,$@) compile
+ @touch $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@
%-install: %-compile
- @[ -f $(STAMP_DIR)/.toolchain_$@ ] || $(MAKE) -C $(patsubst %-install,%,$@) install
- @touch $(STAMP_DIR)/.toolchain_$@
+ @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || $(MAKE) -C $(patsubst %-install,%,$@) install
+ @touch $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@
%-clean:
@$(MAKE) -C $(patsubst %-clean,%,$@) clean
- @rm -f $(STAMP_DIR)/.toolchain_$(patsubst %-clean,%,$@)-*
+ @rm -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$(patsubst %-clean,%,$@)-*