summaryrefslogtreecommitdiff
path: root/openwrt/toolchain/gcc/Makefile.in
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2005-01-16 11:43:02 +0000
committerMike Baker <mbm@openwrt.org>2005-01-16 11:43:02 +0000
commit76d90c2ed2956d27e0c8af8fb0b76b3069228d5f (patch)
tree986493f1905c17f3a385831d60709492c4c5ed7a /openwrt/toolchain/gcc/Makefile.in
parenta5e92562f883bbd64e84b69bb683f42911ec7036 (diff)
downloadmtk-20170518-76d90c2ed2956d27e0c8af8fb0b76b3069228d5f.zip
mtk-20170518-76d90c2ed2956d27e0c8af8fb0b76b3069228d5f.tar.gz
mtk-20170518-76d90c2ed2956d27e0c8af8fb0b76b3069228d5f.tar.bz2
Initial revision
SVN-Revision: 197
Diffstat (limited to 'openwrt/toolchain/gcc/Makefile.in')
-rw-r--r--openwrt/toolchain/gcc/Makefile.in26
1 files changed, 26 insertions, 0 deletions
diff --git a/openwrt/toolchain/gcc/Makefile.in b/openwrt/toolchain/gcc/Makefile.in
new file mode 100644
index 0000000..2963ffb
--- /dev/null
+++ b/openwrt/toolchain/gcc/Makefile.in
@@ -0,0 +1,26 @@
+GCC_VERSION:=$(strip $(subst ",, $(BR2_GCC_VERSION)))
+#"
+GCC_USE_SJLJ_EXCEPTIONS:=$(strip $(subst ",, $(BR2_GCC_USE_SJLJ_EXCEPTIONS)))
+#"
+TARGET_OPTIMIZATION:=$(strip $(subst ",, $(BR2_TARGET_OPTIMIZATION)))
+#""
+
+
+ifeq ($(BR2_SOFT_FLOAT),y)
+# gcc 3.4.x soft float configuration is different than previous versions.
+ifeq ($(findstring 3.4.,$(GCC_VERSION)),3.4.)
+SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
+else
+SOFT_FLOAT_CONFIG_OPTION:=--without-float
+endif
+TARGET_SOFT_FLOAT:=-msoft-float
+ARCH_FPU_SUFFIX:=_nofpu
+else
+SOFT_FLOAT_CONFIG_OPTION:=
+TARGET_SOFT_FLOAT:=
+ARCH_FPU_SUFFIX:=
+endif
+
+ifeq ($(strip $(BR2_PACKAGE_GCC_TARGET)),y)
+TARGETS+=gcc_target
+endif