summaryrefslogtreecommitdiff
path: root/openwrt/toolchain/gcc/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2006-01-28 15:34:33 +0000
committerImre Kaloz <kaloz@openwrt.org>2006-01-28 15:34:33 +0000
commitc8100208bedd2304935edbece05575e446ba9f89 (patch)
treededad0162d2884adbe2cff3061d50b3ba8f910d9 /openwrt/toolchain/gcc/Makefile
parentbbacefc5e1175e80e15cb944d928b100b4cdb12f (diff)
downloadmtk-20170518-c8100208bedd2304935edbece05575e446ba9f89.zip
mtk-20170518-c8100208bedd2304935edbece05575e446ba9f89.tar.gz
mtk-20170518-c8100208bedd2304935edbece05575e446ba9f89.tar.bz2
fix libgcc handling for gcc 3.4.5 and 4.0.2
SVN-Revision: 3063
Diffstat (limited to 'openwrt/toolchain/gcc/Makefile')
-rw-r--r--openwrt/toolchain/gcc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/toolchain/gcc/Makefile b/openwrt/toolchain/gcc/Makefile
index 57debe1..642662e 100644
--- a/openwrt/toolchain/gcc/Makefile
+++ b/openwrt/toolchain/gcc/Makefile
@@ -194,8 +194,8 @@ endif
# to include a reference to libgcc.so.1 in all binaries. For flash space
# saving, we change the specs file to link in a static libgcc here.
if [ ! -f $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs ] ; then \
- echo staging dir specs file is missing ; \
- /bin/false ; \
+ echo staging dir specs file is missing, assuming GCC 4.x ; \
+ $(STAGING_DIR)/bin/$(REAL_GNU_TARGET_NAME)-gcc -dumpspecs > $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs; \
fi;
if grep -q as-needed $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs; then \
patch -d $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/ -p0 < ./$(GCC_VERSION)/static-libgcc.patch.conditional ; \