summaryrefslogtreecommitdiff
path: root/openwrt/toolchain/gcc
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2006-01-04 08:37:19 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2006-01-04 08:37:19 +0000
commite74f05f29b3b0bc6e3e0cfb83a10a1a9cdcea2df (patch)
tree6b5fd954a8bceb44d8c0716b5017b18ae7a2292a /openwrt/toolchain/gcc
parent1c59bfaaf40a3da51600e2fbfff62cfd85012fd9 (diff)
downloadmtk-20170518-e74f05f29b3b0bc6e3e0cfb83a10a1a9cdcea2df.zip
mtk-20170518-e74f05f29b3b0bc6e3e0cfb83a10a1a9cdcea2df.tar.gz
mtk-20170518-e74f05f29b3b0bc6e3e0cfb83a10a1a9cdcea2df.tar.bz2
patch for spec file of gcc 3.4.4, so that libgss library is not automatically linked into every binary. explicitely link it into needed packages (kismet, nmap, samba) and add dependencies. idea and patch from sven-ola, thx. Saves 16 kb in the default squashfs images.
SVN-Revision: 2817
Diffstat (limited to 'openwrt/toolchain/gcc')
-rw-r--r--openwrt/toolchain/gcc/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/openwrt/toolchain/gcc/Makefile b/openwrt/toolchain/gcc/Makefile
index dc7e02c..f6f4aca 100644
--- a/openwrt/toolchain/gcc/Makefile
+++ b/openwrt/toolchain/gcc/Makefile
@@ -188,6 +188,16 @@ ifeq ($(findstring 3.3.,$(GCC_VERSION)),3.3.)
cp ./$(GCC_VERSION)/specs-$(ARCH)-soft-float $(STAGING_DIR)/lib/gcc-lib/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs
endif
endif
+# We do another ugly hack here because the standard behaviour is
+# to include a reference to libgcc.so.1 in all binaries. For flash space
+# saving, we change the specs file to link in a static libgcc here.
+ if [ ! -f $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs ] ; then \
+ echo staging dir specs file is missing ; \
+ /bin/false ; \
+ fi;
+ if grep -q as-needed $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs; then \
+ patch -d $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/ -p0 < ./$(GCC_VERSION)/static-libgcc.patch.conditional ; \
+ fi;
source: $(DL_DIR)/$(GCC_SOURCE)
prepare: $(STAGING_DIR)/bin/$(REAL_GNU_TARGET_NAME)-gcc